Door locks not working correctly... - Team Camaro Tech
Troubleshooting Diagnosing problems done here.

 
LinkBack Thread Tools Display Modes
post #1 of 4 (permalink) Old Aug 18th, 00, 07:42 AM Thread Starter
BC
 
Join Date: Sep 1998
Posts: 470
Question

After reading another post about doors getting stuck, I thought maybe you gurus could help me out with my seemingly minor problem. I have a '70 plain jane kinda car that has problems unlocking. It seems that when it is locked, you have to try several times before it will 'catch' and unlock, otherwise, the locking knob just goes up and down without doing anything. It does this whether you are trying from the outside with the key, or from the inside with the knob. After a couple of tries (usually three which has become kinda a joke among friends) you can feel it catch and work fine. I assume something is worn, but have no idea what to look for. Thanks for the help, you guys are great!!

BC
BC is offline  
Sponsored Links
Advertisement
 
post #2 of 4 (permalink) Old Aug 18th, 00, 09:48 AM
Senior Tech
 
Join Date: Mar 2000
Posts: 715
Post

Check the lock linkage rods behind the door panel.

------------------
68 RS, Ash Gold,pwr windows,Hounds tooth
CA420 is offline  
post #3 of 4 (permalink) Old Aug 18th, 00, 12:28 PM
Senior Tech
Brad
 
Join Date: Jun 2000
Location: Summit, MS
Posts: 646
Post

This seems like a lot time but you can do this. Take off the door panel on the correctly working side and compare it to the non working side. Just look at all the moving parts and you should be able to deterime the problem
Brad74 is offline  
 
post #4 of 4 (permalink) Old Aug 20th, 00, 06:37 AM
Gold Lifetime Member
Jim
 
Join Date: Dec 1999
Location: Yorkville, Illinois USA
Posts: 22,121
Post

Taking off the inside door panel, and coating all the moving parts with WD40 will loosen things up. Since it works sometimes, i doubt that anything is broke, just sticky.



JimM is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Team Camaro Tech forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address.
NOTE we receive a lot of registrations with bad email addresses. IF you do not receive your confirmation email you will not be able to post. contact support and we will try and help.
Be sure you enter a valid email address and check your spam folder as well.



Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome