fading fuel pressure - Team Camaro Tech
Troubleshooting Diagnosing problems done here.

 
LinkBack Thread Tools Display Modes
post #1 of 3 (permalink) Old Feb 26th, 01, 03:49 PM Thread Starter
Senior Tech
 
Join Date: Jan 2001
Location: conway s.c.
Posts: 168
Lightbulb

have an '89 iroc-z 350 tpi, usually takes about three tries to start. pump works fine, new match flowed msd injectors (22 lbs.) put fuel pressure tester on it& got 50 psi momentarily with key on. pressure dropped to 47 psi and slowly faded to about 12 psi. with engine running pressure holds at 40 psi. checked fuel lines under hood. no kinks, fuel leaks, or fuel smell. also changed fuel vent valve. think i might have a pinched fuel inlet line somewhere. any suggestions?
trickster is offline  
Sponsored Links
Advertisement
 
post #2 of 3 (permalink) Old Feb 26th, 01, 04:43 PM
Senior Tech
 
Join Date: Dec 1999
Location: Meridian, Idaho
Posts: 321
Post

I had a pump do that to me once and replaced it. Also had a plugged fuel filter. Owned many a TPI.
camaroguy is offline  
post #3 of 3 (permalink) Old Feb 26th, 01, 06:18 PM
Senior Tech
Dale
 
Join Date: Sep 2000
Location: Glendale,AZ.U.S.A.
Posts: 966
Post

Pinch off the pressure and return hoses with fuel pressure in them.If the pressure drops,the injectors are leaking.If it holds pressure,drop off the pressure side clamp.If the pressure drops,thecheck valve in pump is leaking.Do the same on the return,if it drops,the regulator is leaking.

------------------
68 z28 ,68 rs 327 ,73 454 vette, 2 goofy kids
dale68z is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Team Camaro Tech forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address.
NOTE we receive a lot of registrations with bad email addresses. IF you do not receive your confirmation email you will not be able to post. contact support and we will try and help.
Be sure you enter a valid email address and check your spam folder as well.



Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome