muffer sound like a shotgun - Team Camaro Tech
Troubleshooting Diagnosing problems done here.

 
LinkBack Thread Tools Display Modes
post #1 of 2 (permalink) Old Jun 28th, 04, 08:02 PM Thread Starter
 
Join Date: Jun 2004
Location: VACAVILLE
Posts: 10
Post

i just install a new edelbrock carb, edelbrock intake air gap, edelbrock airfilter, hooker header, and custom pipe. Whenever the car is started the muffer sound like a shotgun bang bang etc.. Can someone here tell me what to look for or do so i wont get the cop call on me or people from jumpin to the ground. Thank you
YEAR69 is offline  
Sponsored Links
Advertisement
 
post #2 of 2 (permalink) Old Jun 29th, 04, 02:16 AM
Senior Tech
Mark
 
Join Date: Sep 2000
Location: Shrewsbury, MA, USA
Posts: 6,509
Post

Check your spark plug wires for the correct firing order. Could be your firing a cylinder with the exhaust valve open.

Mark Canning
1969 Indy Pace Car
350/300HP RPO Z11

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
Mark C is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Team Camaro Tech forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address.
NOTE we receive a lot of registrations with bad email addresses. IF you do not receive your confirmation email you will not be able to post. contact support and we will try and help.
Be sure you enter a valid email address and check your spam folder as well.



Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome