low fuel light stays on ? - Team Camaro Tech
Troubleshooting Diagnosing problems done here.

 
LinkBack Thread Tools Display Modes
post #1 of 4 (permalink) Old Mar 11th, 01, 02:19 PM Thread Starter
Tech Team
 
Join Date: Sep 2000
Location: gilbert,az 85296
Posts: 42
Post

even when 3/4 full the low fuel light is on...any idea on a fix? thanx,david

------------------
1969 z11 pace car.396/350 hp..1997 30th convertible prickyard pace car [email protected]
69 z-11 is offline  
Sponsored Links
Advertisement
 
post #2 of 4 (permalink) Old Mar 12th, 01, 07:54 AM
Senior Tech
Mark
 
Join Date: Sep 2000
Location: Shrewsbury, MA, USA
Posts: 6,509
Post

New Low fuel light Sending unit. It's mounted in the console between the fuel and oil pressure gauge. Or you can try to repair the burnt out transistors and diode inside the sending unit.

There was a recent thread in the electical section on this same subject.




------------------
Mark Canning
1969 Indy Pace Car
350/300HP RPO Z11
Mark C is offline  
post #3 of 4 (permalink) Old Mar 12th, 01, 01:42 PM
Senior Tech
Steve
 
mccorry's Avatar
 
Join Date: Apr 1999
Location: Grove City, Ohio, USA
Posts: 1,642
Garage
Wink

Hey, David.... If you need help, drop me a line. I just went through this mess. Sounds like you have either a dirty connection, a short to ground, or a fried transistor.

Does the gauge work ok?

------------------
Steve McCorry - Central Ohio Camaro Club
'69 Camaro RS/SS-350 - Daytona Yellow
'95 Camaro Z-28 - Sebring Silver
click here to see my webpage ---> www.mindspring.com/~mccorry (updated 3/10/01)
mccorry is offline  
 
post #4 of 4 (permalink) Old Mar 12th, 01, 05:44 PM Thread Starter
Tech Team
 
Join Date: Sep 2000
Location: gilbert,az 85296
Posts: 42
Post

thanx mark,and steve....yes my guage works fine..so you think it is a sending unit in the console? this site rocks,i would of never guessed that..will take it apart this weekend...thanx again..david

------------------
1969 z11 pace car.396/350 hp..1997 30th convertible prickyard pace car [email protected]
69 z-11 is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Team Camaro Tech forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address.
NOTE we receive a lot of registrations with bad email addresses. IF you do not receive your confirmation email you will not be able to post. contact support and we will try and help.
Be sure you enter a valid email address and check your spam folder as well.



Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome