coolant level sensor - Team Camaro Tech
Troubleshooting Diagnosing problems done here.

 
LinkBack Thread Tools Display Modes
post #1 of 3 (permalink) Old Aug 1st, 02, 09:40 AM Thread Starter
 
Join Date: Jul 2002
Location: Honolulu, HI
Posts: 1
My coolant level sensor is lighting up on my 1993 Z28 but my coolant system is full...There seems to be no after marker sensors and the dealer said that they stopped making the part..Has anyone else had this problem and where did you get the sensor??
kevin lyons is offline  
Sponsored Links
Advertisement
 
post #2 of 3 (permalink) Old Aug 1st, 02, 12:40 PM
Senior Tech
Don
 
ZZ_430's Avatar
 
Join Date: May 2001
Location: Houston, Texas
Posts: 4,491
Those can usually be cleaned of corrosion and then reinstalled.

That should take care of it.

------------------
Don~ ZZ430DropTop
~~~~and~~~~
70 RS/Z28
67 RS/SS Convertible, 70 RS/Z28
ZZ_430 is offline  
post #3 of 3 (permalink) Old Aug 1st, 02, 03:50 PM
Senior Tech
 
Join Date: Aug 2000
Location: Ft Worth, Tx USA
Posts: 288
If cleaning it don't fix it I think you have to buy the surge tank to get one. If you are the only driver, or check it often just unplug it and go on.

Larry
www.lnjstreetrods.com
lnjstreetrods is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Team Camaro Tech forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address.
NOTE we receive a lot of registrations with bad email addresses. IF you do not receive your confirmation email you will not be able to post. contact support and we will try and help.
Be sure you enter a valid email address and check your spam folder as well.



Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome