Bad clutch? Slave Cylinder? help - Team Camaro Tech
Troubleshooting Diagnosing problems done here.

 
LinkBack Thread Tools Display Modes
post #1 of 2 (permalink) Old Nov 27th, 01, 03:10 AM Thread Starter
 
Join Date: Nov 2001
Location: mascot tn USA
Posts: 1
Question

Would be thankful for any advice.... Built an 84 Camaro Z28. Came with Borg Warner t 5 speed. We put a 69 327 in. The other day my we were in the driveway the clutch pedal just went to nothing and cut the car off. Was not hossing it just idling.Does this sound like the clutch went out Or the Slave cylinder went out.If you mash the pedal THE rubber piece on the cylinder moves a little.Thanks for any help.
junkfarmer is offline  
Sponsored Links
Advertisement
 
post #2 of 2 (permalink) Old Nov 27th, 01, 11:50 AM
Senior Tech
Joe
 
Join Date: Aug 2001
Location: san jose ca usa
Posts: 503
Post

If theres no fliud loss than I would suspect the clutch master cylinder. If you have fliud loss than you need to find where it is leaking from.

------------------
70 camaro 307 (350soon) /350th
Joekool1234567 is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Team Camaro Tech forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address.
NOTE we receive a lot of registrations with bad email addresses. IF you do not receive your confirmation email you will not be able to post. contact support and we will try and help.
Be sure you enter a valid email address and check your spam folder as well.



Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome