Comp Codes... Need Help Please. - Team Camaro Tech
Troubleshooting Diagnosing problems done here.

 
LinkBack Thread Tools Display Modes
post #1 of 4 (permalink) Old Jan 15th, 00, 03:21 PM Thread Starter
 
Join Date: Jan 2000
Posts: 2
Post

I have an 89 RS Conv 305 TBI. It's got 54K miles auto trans. My problem is, i keep getting that **** service engine soon light. The code it pulled first was 32, on a solid light. I read the code book and replaced the EGR valve. Now the light blinks, the RPM's jump, and the code pulled is straight 12 12 12 12 12 12. This is driving me mad. Please help me.
ironwolf is offline  
Sponsored Links
Advertisement
 
post #2 of 4 (permalink) Old Jan 17th, 00, 06:47 AM
Senior Tech
Drake
 
Join Date: Dec 1999
Location: Racine WI
Posts: 204
Cool

I rebuilt the engine on my 88 chevy truck this past fall.when I put it back together it ran o.k.,but I also got a "32" engine code on my dash light,this is the E.G.R. code for my truck also.I tested the EGR with a vacume pump,it was fine.It turned out that I connected the vacume line to the wrong port.This is a shot in the dark,but I would double check the vacume hose connection,the port that mine connects to has a "vent" port right above it,which I mistakenly put the line on.I just used my vacume diagram label under my hood.
Now I should have said this first,but I forgot.From my understanding you SHOULD be getting a "12" code,this just means you are tapped into the system,code 12 is not a fault code.Now this is on my 88 truck,your car may be different.I have also found that when I run the engine while I am "tapped" into the computer,it runs like crap.Make sure you unplug your jumper wire before you start your car,this may be the whole problem!Hope some of this info is useful,auto computers is not a strong subject with me!

------------------
67 RS RAGTOP # matching, 4X4 CHEVY TRUCK
67drake is offline  
post #3 of 4 (permalink) Old Jan 19th, 00, 10:35 AM
 
Join Date: Jan 2000
Location: Ft. Lauderdale, FL
Posts: 15
Wink

12 always flashes and is used to tell you that you are successfully tapping into the computer

i have the Chilton's repair manual for 82-92 camaros it tells you what to do int checking the valve itself to all the wiring in between for this trouble shooting code to pop up on pg. 4-114. They have this book at some car stores and every book store I have been in it costs about 12 bucks and it is worth it. I would explain it but it is very long and complex to explain here.
MustangEater is offline  
 
post #4 of 4 (permalink) Old Jan 20th, 00, 05:17 PM Thread Starter
 
Join Date: Jan 2000
Posts: 2
Post

Thanks for all the help guys. Maybe i didn't make the last part clear enough though. When i stated that after i replaced the EGR and got a blinking service engine soon light, the code that i pulled was 12 12 12 12 12 12, i wasn't making that up. I got 6 12's. That was the code. And no it is not a code that tells you that you that the code portion of the computer is working, according to Chevy, code 12 is no refrence pulse from the distributer. You will get this whenever you check for a code while the engine is NOT running.

Eater, i do have the chiltons and the haynes manuals for the car. I also have the Alldata info for it but i still can't figure out what the problem is. And Drake, i did leave the jumper in once. But it makes the engine run bad from the start. My problem is after a 5-10 minute running time. Again thanx for you input. But i think this is going to be a job for someone with a lot more experiance than me, and is able to see what i'm talking about. Thanx again.
ironwolf is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Team Camaro Tech forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address.
NOTE we receive a lot of registrations with bad email addresses. IF you do not receive your confirmation email you will not be able to post. contact support and we will try and help.
Be sure you enter a valid email address and check your spam folder as well.



Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome