running rich at idle (PLEASE HELP) - Team Camaro Tech
Troubleshooting Diagnosing problems done here.

 
LinkBack Thread Tools Display Modes
post #1 of 4 (permalink) Old Oct 21st, 03, 03:13 PM Thread Starter
 
Join Date: Aug 2003
Posts: 14
Post

i have a 350 with a lunati cam with .457 lift and a 600 holley vaccum secondary carb on it. My problem is that at idle it runs overly rich at idle and sounds like it has no power and loads up at a stoplight. But as 60 or 70 mph. it runs like a scolded dogand better than any other car. When I drive it hard or for an hour at long distances at finally stop the idle speed seems like it is too high and sounds like its running away. But when I drive for about 20 minutes when I stop the car sounds mean and idles fine until it starts to load up. When I floor it off idle it bogs and falls flat on its face. COuld I just lean it out at idle with the mixture screw or could it be a blown power valve butI just repalced it not too long ago. Please I need some help so I can enjoy my car.
silver67 is offline  
Sponsored Links
Advertisement
 
post #2 of 4 (permalink) Old Oct 22nd, 03, 05:17 AM
DjD
Retired
Dennis
 
DjD's Avatar
 
Join Date: Apr 1999
Location: Fortuna, CA
Posts: 26,453
Garage
Post

Tuning a Holley has been covered here many many times... Search on "Holley" in the Performance forum. There's lots that will help.

...Dennis

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


"Don't take life so serious, you won't get out alive..."
DjD is offline  
post #3 of 4 (permalink) Old Oct 24th, 03, 06:08 AM
Gold Lifetime Member
Jim
 
Join Date: Dec 1999
Location: Yorkville, Illinois USA
Posts: 22,121
Post

sounds like your power valve is opening at idle, low vacuam with that cam....





To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.



To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
New website for my vert is coming together. Do ya like the slide show on the home page?
JimM is offline  
 
post #4 of 4 (permalink) Old Oct 25th, 03, 11:14 PM
Senior Tech
 
Join Date: May 2001
Location: Ashby,MN, USA
Posts: 8,305
Post

is the choke opening up?

you don't plan sincerity.
you have to make it up on the spot.

wanna hear about 20 years ago when i was too smart to know any better?
novaderrik is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Team Camaro Tech forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address.
NOTE we receive a lot of registrations with bad email addresses. IF you do not receive your confirmation email you will not be able to post. contact support and we will try and help.
Be sure you enter a valid email address and check your spam folder as well.



Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome