pinging and missing - Team Camaro Tech
Troubleshooting Diagnosing problems done here.

 
LinkBack Thread Tools Display Modes
post #1 of 9 (permalink) Old Mar 18th, 01, 12:10 PM Thread Starter
Tech Team
 
Join Date: Mar 2001
Posts: 49
Cool

I have a 92 Camaro with a 305 tbi, when I sit at idle there is a slight miss in the engine sometimes, sometimes its smooth. Also I hear it pinging when I floor it. I've replaced the fuel filter, adjusted the timing, replaced cap, plugs, and wires. I am thinking maybe my injectors might be bad; they appear to be putting out a good misting halo, but I'm out of ideas. Any help would be appreciated.
jamesbern is offline  
Sponsored Links
Advertisement
 
post #2 of 9 (permalink) Old Mar 18th, 01, 12:15 PM
 
Join Date: Mar 2001
Location: durhamville,ny,us
Posts: 26
Post

check your egr system, the valve could be sticking intermittantly, causing a miss/skip noticeable at idle could also cause pinging problem. hope this helps.

------------------
71 camaro ss 66 chevelle 396/4spd www.americaniron.net
tom billings is offline  
post #3 of 9 (permalink) Old Mar 18th, 01, 01:25 PM Thread Starter
Tech Team
 
Join Date: Mar 2001
Posts: 49
Post

Thank you I will do that.
jamesbern is offline  
 
post #4 of 9 (permalink) Old Mar 19th, 01, 03:19 PM Thread Starter
Tech Team
 
Join Date: Mar 2001
Posts: 49
Post

I checked the egr valve, but it is in excellent working condition and has not the slighest hint of carbon.
jamesbern is offline  
post #5 of 9 (permalink) Old Mar 19th, 01, 07:30 PM
Senior Tech
 
Join Date: Dec 2000
Location: Monroe, WA, USA
Posts: 312
Post

when timeing the motor, dose the timing mark jump around??? if so a bad timing chain. also you could have a bit-o-carbon built up in the motor and you will get this too.

leaking valve guid's and or seal's can cause this too.

a minor vaccum leak at the intake too.

while idleing spray the intake manifold edges and with carb cleaner if the motor smooth's out you have a leak.

next un-plug the PCV valve. block off the hole and the fresh air inlet hole. soray sone carb cleaner into the vavle cover through the oil fill hole. if the idle change's you could have a intake leak on the inside or valve guid' leaking or valve guid seal's.

hope this help's.
ilbl8 is offline  
post #6 of 9 (permalink) Old Mar 20th, 01, 02:28 PM Thread Starter
Tech Team
 
Join Date: Mar 2001
Posts: 49
Post

The timing chain is in good shape, we ran a complete topend cleaning on the engine, and I haven't yet found a vacuum leak though I will check some more. I am leaning towards the valve guides being worn out. The poor car has 187,000 on the orginal engine, but it was well taken care of. If I don't find any vacuum leaks I'll just assume its in the heads and not worry about it. I am planning on replacing that weak 305 anyway. I thank you gentlemen for your time and speedy answers and will let you know if I find the problem. Thanks again!!!!
jamesbern is offline  
post #7 of 9 (permalink) Old Mar 20th, 01, 06:08 PM
 
Join Date: Mar 2001
Posts: 24
Post

Are you using premium fuel? That might help the pinging. If you are not using it already...

------------------
1981Z28 1969Caprice396 1981TransAm Nascar Pace Car
TJMZ288 is offline  
post #8 of 9 (permalink) Old Mar 20th, 01, 06:10 PM Thread Starter
Tech Team
 
Join Date: Mar 2001
Posts: 49
Post

The best I can get is 92 octane which should be sufficient, but I've tried dumping octane boost on top of that with no results. Today it didn't do it, yesterday it did, who knows?
jamesbern is offline  
post #9 of 9 (permalink) Old Mar 21st, 01, 01:38 PM Thread Starter
Tech Team
 
Join Date: Mar 2001
Posts: 49
Cool

The problem was my oxygen sensor. Usually they overfuel and blow black smoke or have a smelly exhaust, but this one was different.
I'd like to thank you all for your help.
jamesbern is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Team Camaro Tech forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address.
NOTE we receive a lot of registrations with bad email addresses. IF you do not receive your confirmation email you will not be able to post. contact support and we will try and help.
Be sure you enter a valid email address and check your spam folder as well.



Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome