speedo cable/gear problems... th400 - Team Camaro Tech
Troubleshooting Diagnosing problems done here.

 
LinkBack Thread Tools Display Modes
post #1 of 1 (permalink) Old Mar 8th, 04, 11:41 PM Thread Starter
Senior Tech
Marc
 
Join Date: Jun 2001
Location: Cedar Rapids, IA
Posts: 734
Question

I posted this in the tranny section and hadn't found any help yet, but there was another person having the same problem. I'm hooking up my speedo cable in my 67 and it appears that either the cable end or the gearing is wrong. I took out a th350 and puttin in a th400. Rick's First Generation says I have the right cable. The th400 is out of a 68 Chevelle. The square cable end turns inside the square gear. Is there an adapter or fitting to make this work? Could the gear be worn out?

Marc


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


67 Camaro, 454, TH400, 9" 4.11's
camaro man is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Team Camaro Tech forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address.
NOTE we receive a lot of registrations with bad email addresses. IF you do not receive your confirmation email you will not be able to post. contact support and we will try and help.
Be sure you enter a valid email address and check your spam folder as well.



Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome