metal noise - Team Camaro Tech
Troubleshooting Diagnosing problems done here.

 
LinkBack Thread Tools Display Modes
post #1 of 3 (permalink) Old Mar 27th, 02, 03:30 PM Thread Starter
 
Join Date: Feb 2002
Location: Frankfort, IL USA
Posts: 6
I have a 94 Z 28, and it just recently started to make almost a metal grinding noise everytime i am going very slowly in reverse or drive. I am not a car expert, but could this problem be the brakes, or is this a very major problem?
Thanks
94z28 is offline  
Sponsored Links
Advertisement
 
post #2 of 3 (permalink) Old Mar 27th, 02, 04:00 PM
 
Join Date: Mar 2002
Location: Ky, USA
Posts: 28
If the noise changes when you press the brake pedal, chances are its your brakes. If not. maybe your Ujoints,
flattop is offline  
post #3 of 3 (permalink) Old Mar 27th, 02, 05:41 PM
Senior Tech
Dave
 
Join Date: Sep 2001
Location: Yorkville In
Posts: 1,420
Sounds like your brake pad wear indicators are rubbing. This accures when the pads are wore out .
Branded is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Team Camaro Tech forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address.
NOTE we receive a lot of registrations with bad email addresses. IF you do not receive your confirmation email you will not be able to post. contact support and we will try and help.
Be sure you enter a valid email address and check your spam folder as well.



Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome