Spark plug Help - Team Camaro Tech
Troubleshooting Diagnosing problems done here.

 
LinkBack Thread Tools Display Modes
post #1 of 3 (permalink) Old May 12th, 01, 12:25 PM Thread Starter
 
Join Date: May 2000
Location: vian ok
Posts: 15
Angry

I have a 85 tpi 305 camaro rebuilt it 1,000 miles ago. The problem is the sparkplugs they still look brand new. They are not brown black or grey I mean they look like I just put them in. The only problem I have is a slight jerk or stumble at about 1500rpm's otherwise it runs great start's great hot or cold. I can't tell whether it runs rich or lean cause the plugs don't look like anything in my books they only look new. They all are firing pulled each injector harness off one at a time and you could tell a difference also pulled each wire off and they are all firing. The motor is compleltly stock except for a small cam. Why do they look like this. Need serious Help
white 78 is offline  
Sponsored Links
Advertisement
 
post #2 of 3 (permalink) Old May 12th, 01, 12:36 PM
Senior Tech
 
Join Date: Feb 2001
Location: Concord Cal. USA
Posts: 2,664
Post

I can't help you on the stumble but if there are no signs of detonation that is how a comp. controlled FI. plug should look.

oger is offline  
post #3 of 3 (permalink) Old May 12th, 01, 12:56 PM Thread Starter
 
Join Date: May 2000
Location: vian ok
Posts: 15
Post

Thanks for the quick reply I just thought it was weird that it didn't look like anything in my books
white 78 is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Team Camaro Tech forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address.
NOTE we receive a lot of registrations with bad email addresses. IF you do not receive your confirmation email you will not be able to post. contact support and we will try and help.
Be sure you enter a valid email address and check your spam folder as well.



Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome