hesitant - Team Camaro Tech
Troubleshooting Diagnosing problems done here.

 
LinkBack Thread Tools Display Modes
post #1 of 10 (permalink) Old Oct 29th, 01, 07:09 AM Thread Starter
 
Join Date: Oct 2001
Posts: 18
Post

i need some help.i own a 94 z28.when i'm driving and pressing down on the gas only slightly,it runs kind of rough and feels hesitant,but when i push the gas farther down it feels and runs fine.anybody have any idea of what could be wrong?
st20 is offline  
Sponsored Links
Advertisement
 
post #2 of 10 (permalink) Old Oct 29th, 01, 08:52 AM
Senior Tech
 
Join Date: May 2000
Location: Westlake, OH 44145
Posts: 707
Post

Poss overactive EGR valve, If its Vac operated.
Milan is offline  
post #3 of 10 (permalink) Old Oct 29th, 01, 01:58 PM
Stephen Dale
Guest
 
Posts: n/a
Post

The TPS may have a dead spot. Check with a DIGITAL ohm meter. Do you get any OBD codes?

------------------

67 Nemesix
 
post #4 of 10 (permalink) Old Oct 29th, 01, 04:20 PM Thread Starter
 
Join Date: Oct 2001
Posts: 18
Post

no codes.it is most noticible goig up hill.
st20 is offline  
post #5 of 10 (permalink) Old Oct 30th, 01, 07:54 AM Thread Starter
 
Join Date: Oct 2001
Posts: 18
Post

after paying real close attention,i've realized that it only runs that way at 45mph and 1500rpm.it even does it on cruise control.you can see the rpms jump slightly.
st20 is offline  
post #6 of 10 (permalink) Old Oct 30th, 01, 08:11 AM
Senior Tech
Don
 
ZZ_430's Avatar
 
Join Date: May 2001
Location: Houston, Texas
Posts: 4,491
Question

Is it a 6 speed or automatic?

------------------
Don~ ZZ430DropTop
~~~~and~~~~
Pro-Touring.com DropTop
67 RS/SS Convertible, 70 RS/Z28
ZZ_430 is offline  
post #7 of 10 (permalink) Old Oct 30th, 01, 09:08 AM Thread Starter
 
Join Date: Oct 2001
Posts: 18
Post

AUTOMATIC
st20 is offline  
post #8 of 10 (permalink) Old Oct 30th, 01, 09:41 AM
Senior Tech
Don
 
ZZ_430's Avatar
 
Join Date: May 2001
Location: Houston, Texas
Posts: 4,491
Post

Ok, I'm thinking about torque lock-up operation. Try putting shifter in "D" rather than "OD" and see if that makes any difference.

------------------
Don~ ZZ430DropTop
~~~~and~~~~
Pro-Touring.com DropTop
67 RS/SS Convertible, 70 RS/Z28
ZZ_430 is offline  
post #9 of 10 (permalink) Old Oct 30th, 01, 10:14 AM Thread Starter
 
Join Date: Oct 2001
Posts: 18
Post

in does it in D at 50mph 2000rpm,but it's really only noticible going uphill.it's not nearly as bad as overdrive.
st20 is offline  
post #10 of 10 (permalink) Old Oct 30th, 01, 03:35 PM
 
Join Date: Oct 2001
Posts: 4
Post

it might be your opti-spark
97/RS is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Team Camaro Tech forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address.
NOTE we receive a lot of registrations with bad email addresses. IF you do not receive your confirmation email you will not be able to post. contact support and we will try and help.
Be sure you enter a valid email address and check your spam folder as well.



Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome