wet or moisture in engine causes big problem - Team Camaro Tech
Troubleshooting Diagnosing problems done here.

 
LinkBack Thread Tools Display Modes
post #1 of 2 (permalink) Old Mar 6th, 04, 06:38 AM Thread Starter
 
Join Date: Mar 2004
Posts: 2
Question

I have an 83 Z28 thst in the past few years has had a big problem with starting when the engine gets wet or has moisture on it. Sometimes it will start and sounds fine, but will let me sit a few miles down the road. After it dries out it will work fine until the next time. We replaced the distributor cap, but that didn't make a difference. Any suggestions???

Thanks,
Deva---83 Z28
Deva is offline  
Sponsored Links
Advertisement
 
post #2 of 2 (permalink) Old Mar 6th, 04, 08:32 AM
Moderator
Bill
 
Join Date: Aug 1998
Location: Waldorf Md. USA
Posts: 3,280
Post

Deva,
You probably need to go through and replace all the ignition high voltage components. Plug wires, cap and rotor, probably plugs also. Use a good set of GM wires and make sure to use the silicon "grease" they give you with the wires. If you want to really see what is happening, wait until after dark, open the hood and spray a light mist of water from the hose on everything, then get someone to start the car while you watch. You will see the "light show" wherever the wires are arcing etc.
Have fun,

Bill Koustenis
Owner
Advanced Automotive Machine
Waldorf Md
1971 Chevelle "Heavy Chevy" original owner


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
BillK is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Team Camaro Tech forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address.
NOTE we receive a lot of registrations with bad email addresses. IF you do not receive your confirmation email you will not be able to post. contact support and we will try and help.
Be sure you enter a valid email address and check your spam folder as well.



Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome