back flushing heater core - Team Camaro Tech
Troubleshooting Diagnosing problems done here.

 
LinkBack Thread Tools Display Modes
post #1 of 1 (permalink) Old Sep 21st, 02, 12:07 PM Thread Starter
Senior Tech
 
Join Date: Nov 2001
Posts: 145
What is the proceedure for back flushing the heater core on a 94 z-28. I had the radiator flushed, and since then there has been no hot air from the heater. I have put in a new thermostat and radiator cap, and I have tried squeezing the hoses to remove air, but still only get cool air. I was told there may be a blockage at the core and that I should try to back flush it. Any help on this, or any other suggestions are appreciated. Thanks.
yogi is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Team Camaro Tech forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address.
NOTE we receive a lot of registrations with bad email addresses. IF you do not receive your confirmation email you will not be able to post. contact support and we will try and help.
Be sure you enter a valid email address and check your spam folder as well.



Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome