Non-Camaro diagnostic question - Team Camaro Tech
Troubleshooting Diagnosing problems done here.

 
LinkBack Thread Tools Display Modes
post #1 of 9 (permalink) Old Sep 16th, 14, 12:01 PM Thread Starter
Gold Lifetime Member
Ken
 
Join Date: Sep 1999
Location: Missouri
Posts: 2,455
Send a message via AIM to Winch Send a message via MSN to Winch
Non-Camaro diagnostic question

Maybe some one here can help with a problem I'm having with my 2002 S10 pickup. When I turn the key to start it I get nothing. Everything lights up when the key is turned on and I'm pretty sure I have a good battery. It has had a problem for some time now where it would do this and all I had to do was jiggle the key and turn the steering wheel or take it out of gear and back in etc. There has been times when I removed the key and the warning beep keeps sounding like I've left the key in etc. I think it is an electrical problem in the steering column / key mechanism.

Any suggestions?
Winch is offline  
Sponsored Links
Advertisement
 
post #2 of 9 (permalink) Old Sep 16th, 14, 03:24 PM Thread Starter
Gold Lifetime Member
Ken
 
Join Date: Sep 1999
Location: Missouri
Posts: 2,455
Send a message via AIM to Winch Send a message via MSN to Winch
Re: Non-Camaro diagnostic question

I was thinking if I can figure out how to jump the starter with the key turned on it should start and hopefully stay running so that I can take it to a shop. Any one know what terminals on the starter to jump together?
Winch is offline  
post #3 of 9 (permalink) Old Sep 16th, 14, 05:26 PM
Senior Tech
B
 
Join Date: Dec 2004
Location: BA, Oklahoma
Posts: 853
Re: Non-Camaro diagnostic question

Sounds like your ignition switch is going bad?

Formers: 1969 RS 350, 700HP 1967 Flash-in-a-pan Firebird 400, 2002 Z28 M6 1SC/1SZ
SnakeEyes is offline  
 
post #4 of 9 (permalink) Old Sep 16th, 14, 05:49 PM
Senior Tech
Chad
 
cv2065's Avatar
 
Join Date: Jul 2012
Location: Orlando, FL
Posts: 1,193
Re: Non-Camaro diagnostic question

I would start with the battery. Pull it and have it load tested at your local auto parts.

67 Black RS Coupe, 383, M21 & 10 Bolt Posi. Edelbrock E-Tech 170 Heads, 2204 Roller Cam, Air Gap Intake.
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
cv2065 is offline  
post #5 of 9 (permalink) Old Sep 16th, 14, 09:05 PM
Gold Lifetime Member
John
 
Join Date: Dec 2008
Location: Louisville, Ky.
Posts: 3,403
Re: Non-Camaro diagnostic question

Might pay to check neutral safety switch too.
john68 is offline  
post #6 of 9 (permalink) Old Sep 17th, 14, 08:06 PM
Gold Lifetime Member
Scott
 
scblucam's Avatar
 
Join Date: May 2005
Location: Houston, TX
Posts: 2,317
Garage
Re: Non-Camaro diagnostic question

Quote:
Might pay to check neutral safety switch too.
Bingo

68 302 M20 - 85 IROC Z
The older I get the faster I was.
scblucam is offline  
post #7 of 9 (permalink) Old Sep 24th, 14, 08:40 AM Thread Starter
Gold Lifetime Member
Ken
 
Join Date: Sep 1999
Location: Missouri
Posts: 2,455
Send a message via AIM to Winch Send a message via MSN to Winch
Re: Non-Camaro diagnostic question

I would think the neutral safety switch but even when it starts OK sometimes it acts weird like it thinks the key is still in it when it's not.

Anyway after viewing enough Utube videos I decided I didn't want to mess with it and it just did it again and this time I couldn't get it to start so I had it towed in. I'll update with what they find out.
Winch is offline  
post #8 of 9 (permalink) Old Sep 25th, 14, 10:28 AM Thread Starter
Gold Lifetime Member
Ken
 
Join Date: Sep 1999
Location: Missouri
Posts: 2,455
Send a message via AIM to Winch Send a message via MSN to Winch
Re: Non-Camaro diagnostic question

They said it was the starter. I've never known one to act like it did. I don't know what jiggling the steering wheel or shift lever had to do with it. I guess I'll find out over time.
Winch is offline  
post #9 of 9 (permalink) Old Sep 25th, 14, 11:20 AM
Senior Tech
Jimmie-Retired
 
Join Date: Sep 2005
Location: S.E. Wyo & Coastal Ala
Posts: 1,036
Re: Non-Camaro diagnostic question

I hope that got it. Sure sounded like the ignition switch or neutral safety switch. I've had a couple of GM ignition switches go bad over the years. One wouldn't turn on and the other wouldn't turn off.

Jim's '69
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


68 SS 396 4 speed A/C Bought New Sold 1976
68 350/350 A/C Bought 1978 $700 Wrecked
69 350 4 Speed Bought 1988
Fried Okra is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Team Camaro Tech forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address.
NOTE we receive a lot of registrations with bad email addresses. IF you do not receive your confirmation email you will not be able to post. contact support and we will try and help.
Be sure you enter a valid email address and check your spam folder as well.



Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome