305 tpi won't Rev past 3500 once warm - Team Camaro Tech
Troubleshooting Diagnosing problems done here.

 
LinkBack Thread Tools Display Modes
post #1 of 4 (permalink) Old Dec 10th, 14, 06:31 PM Thread Starter
josh
 
Join Date: Dec 2014
Location: henley mo
Posts: 1
305 tpi won't Rev past 3500 once warm

Hey I have a 85 305 tpi runs perfect when cold don't miss a beat idles smooth once warm it won't run over 3500 rpms pulls and accelerates great till hit 3500 then like hitting a wall and throws u in dash let of it'll shift pull great again till 3500 dosent miss or spit ot sputter just like hitting rev limiter put new fuel pump/filter has 40 45 lbs pressure has all msd ignition and distributor and coil with adjustable launch setting trying figure out what could be causing this any help would be appreciated
85 camaroirock is offline  
Sponsored Links
Advertisement
 
post #2 of 4 (permalink) Old Dec 10th, 14, 08:16 PM
Gold Lifetime Member
Scott
 
scblucam's Avatar
 
Join Date: May 2005
Location: Houston, TX
Posts: 2,414
Garage
Re: 305 tpi won't Rev past 3500 once warm

Just off hand I think it would be your aftermarket stuff

68 302 M20 - 85 IROC Z
The older I get the faster I was.
scblucam is offline  
post #3 of 4 (permalink) Old Dec 11th, 14, 04:50 AM
Super Moderator
Bess-68's rule
 
Everett#2390's Avatar
 
Join Date: Sep 2000
Location: Va Beach VA
Posts: 31,709
Garage
Re: 305 tpi won't Rev past 3500 once warm

Agree with Scott, eliminate aftermarket items exchanged one at a time.
I would go with the MSD ign box - wire it out of the circuit and go from there.

Give a man a rescued dog for the health of both their souls. May 2017 ROTM Winner - Thank you!
'
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
CUBS - 2016 World Series Champions - Thank you, Joe Madden enjoy your next chapter.
Everett#2390 is offline  
 
post #4 of 4 (permalink) Old Dec 11th, 14, 03:27 PM
Senior Tech
 
Join Date: Mar 2002
Location: Austin, TX, USA
Posts: 5,277
Re: 305 tpi won't Rev past 3500 once warm

It's been a few years since I've worked on a TPI ECM so take this for what it's worth. Some engine controllers (generally speaking) have a rev limiters. Often times the high rev is set to something like 7000 RPM. A few (perhaps many) have a rev limiter that engages at lower RPMs when the car is not in gear. If the TPI ECM has such a feature, perhaps the park / neutral signal is making the ECM think your not in gear and the rev limiter is holding you back.

Dave
========================
68 Coupe, 350 w/ Edelbrock Performer RPM heads, cam, intake, 700R4, Dave's small body HEI
dnult is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Team Camaro Tech forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address.
NOTE we receive a lot of registrations with bad email addresses. IF you do not receive your confirmation email you will not be able to post. contact support and we will try and help.
Be sure you enter a valid email address and check your spam folder as well.



Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome