Help with qft carb - Team Camaro Tech
Troubleshooting Diagnosing problems done here.

 
LinkBack Thread Tools Display Modes
post #1 of 6 (permalink) Old Jul 1st, 15, 07:25 PM Thread Starter
Team Member
James
 
Fitnessguy's Avatar
 
Join Date: Mar 2013
Location: Canada
Posts: 443
Help with qft carb

Okay here's a weird one. Had my carb off the car as it developed a bit of a stumble off idle a couple weeks ago. Fine at speed and wouldn't stumble every time. So pulled the carb apart, cleaned everything thinking maybe was some debris issue. Put the carb on the car today and had the wife whirl it over till I saw the bowls fill up and the primary bowls fills up past the site window! Secondary bowl fills up to middle as always. I did nothing with the float levels when I had it apart so thought okay, needle and seat got stuck. No big deal. Pulled the primary bowl off and looked at the needle and it moved no issue. Pulled the needle anyway to make sure nothing was in there which there wasn't. Set the float level a little lower than I normally had it, put all back together. Whirled over again and the damn thing filled the bowl all the way again! Have a fuel pressure gauge on it and it isn't showing higher than 6lbs which is where it usually is. So what am I missing? I have had the carb apart before and no it well. Other than pull apart to clean, I changed nothing. Stumped
Fitnessguy is offline  
Sponsored Links
Advertisement
 
post #2 of 6 (permalink) Old Jul 1st, 15, 07:55 PM
Gold Lifetime Member
Scott
 
scblucam's Avatar
 
Join Date: May 2005
Location: Houston, TX
Posts: 2,414
Garage
Re: Help with qft carb

Float leaking and sinking because of filling with gas?

68 302 M20 - 85 IROC Z
The older I get the faster I was.
scblucam is offline  
post #3 of 6 (permalink) Old Jul 1st, 15, 08:08 PM Thread Starter
Team Member
James
 
Fitnessguy's Avatar
 
Join Date: Mar 2013
Location: Canada
Posts: 443
Re: Help with qft carb

Quote:
Originally Posted by scblucam View Post
Float leaking and sinking because of filling with gas?
The float looking through the site window is sitting "closed" from what I can see and like I said it isn't showing high pressure. I can get the motor to start if I hold the throttle open a fair bit but as soon as I let the throttle back down it dies obviously because it's flooding.
Fitnessguy is offline  
 
post #4 of 6 (permalink) Old Jul 1st, 15, 08:50 PM
Senior Tech
Scott
 
Join Date: Feb 2013
Location: Southern NH
Posts: 2,457
Re: Help with qft carb

You could try swapping the primary and secondary floats and/or needles & seats with each other to see if the problem moves with the parts when swapped, might help determine what is going on.

69 Camaro Z/28 RS, original Azure Turquoise, M21 & 3.73 12-bolt posi. NOM 406ci, AFR 210 heads, Straub hyd. roller cam & Dynatech 1-3/4" > 1-7/8" headers, QuickFuel 750 Annular. Photos at:
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
NH69Z28RS is offline  
post #5 of 6 (permalink) Old Jul 2nd, 15, 05:25 AM Thread Starter
Team Member
James
 
Fitnessguy's Avatar
 
Join Date: Mar 2013
Location: Canada
Posts: 443
Re: Help with qft carb

So I pulled the primary bowl off again, replaced the needle and seat as I have a rebuild kit on hand. Reset the float even a little lower and put it all back together. Whirled the car over to fill the bowl again and problem solved. Put the old needle/seat beside the new one I put in and they are identical. Both move the same, there isn't a mark or anything on the old one. Don't get it. Oh well at least the problem is solved but not sure how that issue sprung up. Wanted to share the solution.
Fitnessguy is offline  
post #6 of 6 (permalink) Old Jul 2nd, 15, 08:29 PM
Senior Tech
Morgan
 
Join Date: May 2011
Location: Detroit
Posts: 938
Garage
Re: Help with qft carb

Now make sure you throw that needle abs seat in the trash so you don't use it down the road

69 Copo 9560 ZL-1 automatic [email protected], 1.95 on f70-14 polyglas F.AS.T. Race June 2016
69 Copo 9560 ZL-1 4spd [email protected] 1.93 60ft on F70/14
PSMCDR 2014
71LS6 vette [email protected] PSMCDR 2012 SOLD
1971ls6 is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Team Camaro Tech forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address.
NOTE we receive a lot of registrations with bad email addresses. IF you do not receive your confirmation email you will not be able to post. contact support and we will try and help.
Be sure you enter a valid email address and check your spam folder as well.



Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome