96 Camaro 3.8 MAF problem - Team Camaro Tech
Troubleshooting Diagnosing problems done here.

 
LinkBack Thread Tools Display Modes
post #1 of 2 (permalink) Old Feb 6th, 16, 11:04 AM Thread Starter
Tanner
 
Join Date: Feb 2016
Location: USA
Posts: 1
96 Camaro 3.8 MAF problem

I have been having problems with my MAF sensor now for a few months.

When it's plugged in, my car idles terrible, has random misfires, and some times will just lose all the power it has. It also has drastic power missing when its plugged in as well, and feels like im almost towing something with the car.

When I unplug it, car runs great. No idle problems, almost all power back, but I am getting bad fuel mileage now with it unplugged.

I have tried replacing the MAF sensor but it didn't change the problem at all. Anyone able to help me?

First time posting here as well!
ScaddenMan is offline  
Sponsored Links
Advertisement
 
post #2 of 2 (permalink) Old Feb 6th, 16, 01:20 PM
Super Moderator
Bess-68's rule
 
Everett#2390's Avatar
 
Join Date: Sep 2000
Location: Va Beach VA
Posts: 31,709
Garage
Re: 96 Camaro 3.8 MAF problem

Welcome, Tanner.
Is replacement MAF, a new one or a known good one?
A new one can be problematic and used ones can be faulty also.
Is air filter clean?
Are air ducts in good condition - no holes and clamps are tight?
Are other vacuum lines in good condition?

Give a man a rescued dog for the health of both their souls. May 2017 ROTM Winner - Thank you!
'
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
CUBS - 2016 World Series Champions - Thank you, Joe Madden enjoy your next chapter.
Everett#2390 is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Team Camaro Tech forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address.
NOTE we receive a lot of registrations with bad email addresses. IF you do not receive your confirmation email you will not be able to post. contact support and we will try and help.
Be sure you enter a valid email address and check your spam folder as well.



Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome