Bad Relay Switch???????????????????? - Team Camaro Tech
Troubleshooting Diagnosing problems done here.

 
LinkBack Thread Tools Display Modes
post #1 of 3 (permalink) Old May 10th, 05, 06:16 AM Thread Starter
 
Join Date: Feb 2005
Posts: 74
Question Bad Relay Switch????????????????????

With the ignition in the "on" position and i turn the steering wheel left or right there is a "clicking" sound at the relay switch. Also when i connect the horn and put the turn signal in the left or right turn position the horn blows. Is my relay switch bad and this may be causing my other problems? Any help is appreciated thanx.










73'camaro,350/400hp,muncie m-21,hurst comp plus,richmond 3.73 posi 10-bolt 8.5
libb58 is offline  
Sponsored Links
Advertisement
 
post #2 of 3 (permalink) Old May 10th, 05, 06:49 AM
Gold Lifetime Member
Harry
 
dawg's Avatar
 
Join Date: Mar 2004
Location: Colebrook CT.
Posts: 4,052
Re: Bad Relay Switch????????????????????

probably the ignition switch.
or turn signal switch


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

434 stroker
US Navy retired

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
dawg is offline  
post #3 of 3 (permalink) Old May 10th, 05, 08:07 AM
Senior Tech
 
Join Date: Apr 2003
Location: Allen, TX
Posts: 2,108
Re: Bad Relay Switch????????????????????

Check your ground! Make sure you have a good ground from the battery to the passenger fender. I've reproduced this exact problem when I didn't have the radiator support grounded properly via the fender.

1969 Camaro - GM 2003 Electron Blue
Beck Racing 383 cu in 465HP Engine - Sean Murphy Inductions Stage 2 Quadrajet
TCI Streetfighter 350 - 3.73:1 Posi 10 Bolt Rear - 12.6 sec qtr mile

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
and
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
Brian Lewis is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Team Camaro Tech forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address.
NOTE we receive a lot of registrations with bad email addresses. IF you do not receive your confirmation email you will not be able to post. contact support and we will try and help.
Be sure you enter a valid email address and check your spam folder as well.



Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
'69 Horn Question redlines4us Electrical & Wiring 39 Jun 10th, 09 11:31 AM
68 or 69 AC relay switch Black69 Electrical & Wiring 6 Aug 15th, 04 12:32 PM
AC relay switch Black69 Troubleshooting 1 Aug 12th, 04 01:17 PM
67 rs headlights 19673L4P Electrical & Wiring 6 Jun 23rd, 04 02:55 PM
RS Relay Vacuum Switch Indy Z11 Restoration Corner 3 Jun 4th, 04 02:22 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome