Engine dying when hard acceleration... - Team Camaro Tech
Troubleshooting Diagnosing problems done here.

 
LinkBack Thread Tools Display Modes
post #1 of 5 (permalink) Old Jan 17th, 06, 06:41 AM Thread Starter
JL
 
Join Date: May 2004
Posts: 32
Engine dying when hard acceleration...

HI,

i have a 69 camaro RS with a 350 engine.
When I do a hard acceleration from stand position (like at a traffci light),the engine die on me, but if the car is allready running even at slow speed everything is fine. If i accelrate on neutral there is no problem and the engine rev perfetly.

I had a 750 edelbrock which i change for a brand new pretunned 650 edelbrock, butstill have the same problem.
I also update my dual point ignition for a malory ignition but am still runing hte stock coil.

I'm in England and muscle car specialist are not easy to find.

Thanx for your help.

Jimmy
JL is offline  
Sponsored Links
Advertisement
 
post #2 of 5 (permalink) Old Jan 17th, 06, 08:41 AM
Senior Tech
chris
 
Join Date: May 2005
Location: bristol tn
Posts: 254
Re: Engine dying when hard acceleration...

what is your idle at rest in gear?
cfauver is offline  
post #3 of 5 (permalink) Old Jan 17th, 06, 09:13 AM Thread Starter
JL
 
Join Date: May 2004
Posts: 32
Re: Engine dying when hard acceleration...

idle at 600.
JL is offline  
 
post #4 of 5 (permalink) Old Jan 17th, 06, 10:32 AM
 
Join Date: Nov 2005
Posts: 143
Re: Engine dying when hard acceleration...

YOU MIGHT WANT TO CHECK YOUR TIMING TO SEE IF ITS ATLEAST WITHIN FACTORT SPECS. IF IT IS TOO RETARDED YOU WILL YOU WILL HAVE A HESISTATION OR AN OFF IDLE BOG.IF IT STILL PERSISTS CHECK YOUR ACCELERATOR PUMP ON CARB. MAKE SURE IT IS SET PROPERLY ALTHOUGH IT IS HIGHLY UNLIKELY 2 CARBS DOING THE SAME THING....WWW.HARDCOREPARTS.CA
pro1 is offline  
post #5 of 5 (permalink) Old Jan 17th, 06, 01:17 PM Thread Starter
JL
 
Join Date: May 2004
Posts: 32
Re: Engine dying when hard acceleration...

Is this can't come from the coil??? like nor enought spark???? or not going well with the distributor???
JL is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Team Camaro Tech forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address.
NOTE we receive a lot of registrations with bad email addresses. IF you do not receive your confirmation email you will not be able to post. contact support and we will try and help.
Be sure you enter a valid email address and check your spam folder as well.



Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome