Small Problem I hope? - Team Camaro Tech
Troubleshooting Diagnosing problems done here.

 
LinkBack Thread Tools Display Modes
post #1 of 10 (permalink) Old Jan 23rd, 06, 04:29 PM Thread Starter
 
Join Date: Jun 2005
Posts: 4
Unhappy Small Problem I hope?

I just had a newly built 383 stroker v8 small block put in my 1980 camaro and well after driving it a while it started to idle really high now its so loud! and it slows down when you put it into gear but its still quite a bit faster then it should be. It doesnt have that nice slow lub to it like its supposed to and it diesels when you shut it off in park. I was wondering if you thaught this was a minor carborator adjustment or if maybe it was a vaccum problem? Thanks for your input!
camaro_cowgirl is offline  
Sponsored Links
Advertisement
 
post #2 of 10 (permalink) Old Jan 23rd, 06, 04:55 PM
 
Join Date: Nov 2005
Posts: 143
Re: Small Problem I hope?

Although Idle Will Increase Slightly As The Rings Breakin It Wont Happen Immediately...a Vacuum Leak Is More Than Likely The Culprit Or Also Check To Make Sure Your Carb Isnt Slightly Leakin Down.until You Get It Fixed,and Immediately Shut Engine Off In Gear To Avoid The Deiseling......plain Hard On An Engine
pro1 is offline  
post #3 of 10 (permalink) Old Jan 23rd, 06, 05:04 PM
Gold Lifetime Member
Jim
 
Join Date: Dec 1999
Location: Yorkville, Illinois USA
Posts: 22,121
Re: Small Problem I hope?

It could be just a sticky choke, too, possibly even from interference with the air cleaner.
The choke is a round can on the passenger side of the carb, with a rod connecting to the butterfly valve on the top of the front 2 barrels ('scuse me if I'm oversimplifying, please, don't know you and want to make sure what I type is understandable!) There is also a rod that connects to a "fast idle cam" to raise the idle when the choke is closed.

Do this: get the motor warmed up fully. Then take off the air cleaner and look at the choke butterfly, it should be completely open.
Blip the throttle (with the aircleaner still off) and see if the idle settles down. If it did, then the bottom of the air cleaner is interfering with the choke linkage.
If it didn't then blip the throttle while pushing the butterfly valve open with your hand. If the idle setlles down, something is wrong with the choke.

Lets us know what you find, and also what kind of carb you have?





To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.



To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
New website for my vert is coming together. Do ya like the slide show on the home page?
JimM is offline  
 
post #4 of 10 (permalink) Old Jan 23rd, 06, 06:32 PM
Senior Tech
 
Join Date: Mar 2002
Location: Austin, TX, USA
Posts: 5,277
Re: Small Problem I hope?

Fine description Jim. I know I tend to overlook the easy stuff sometimes.

Dave
========================
68 Coupe, 350 w/ Edelbrock Performer RPM heads, cam, intake, 700R4, Dave's small body HEI
dnult is offline  
post #5 of 10 (permalink) Old Jan 23rd, 06, 06:56 PM
Senior Tech
 
Join Date: Jan 2006
Location: Louisville,Ky
Posts: 616
Re: Small Problem I hope?

distributor loose? moved off timing?

sean

You Can't Fake Indifference

69 Camaro Convertible
57 Chevrolet Nomad
Jeeps
buzzworth is offline  
post #6 of 10 (permalink) Old Jan 23rd, 06, 08:09 PM
Senior Tech
Wes
 
Join Date: Dec 2003
Location: Leander, TX
Posts: 2,758
Re: Small Problem I hope?

Agree,..I think your timing as too advanced. You probably need to rotate the distributor clockwise a bit,..should calm her down.

Then get a timing light and set her to 10 degrees and work from there.
Straight-line-69 is offline  
post #7 of 10 (permalink) Old Jan 23rd, 06, 10:24 PM
Senior Tech
Ray P.
 
camaro_fever68's Avatar
 
Join Date: Nov 2005
Location: S. Louisiana
Posts: 655
Re: Small Problem I hope?

I may be wrong, but sounds like idle was set cold and right after warm up, it's idling a little high. Pull the air cleaner and use a flat screw driver to turn the idle down till you like it. You can't miss the idle screw. It's on the side the carb, at the bottom. Sets the butterfly opening.

Ray
camaro_fever68 is offline  
post #8 of 10 (permalink) Old Jan 28th, 06, 05:22 PM
Gold Lifetime Member
 
stevo camaro's Avatar
 
Join Date: Mar 2000
Location: Dunsmuir, CA
Posts: 1,969
Garage
Re: Small Problem I hope?

Quote:
Originally Posted by buzzworth
distributor loose? moved off timing?

sean
That's the first thing I thought too. Had it happen once actually.

67 RS 327, 4-speed, posi, done.
67 Modified, 454, TH-400, posi, under construction.
67 SS 396, 4-speed, basket case.
72 RS, sitting, partially done.
55 210 post, 2 door, 327 4-speed runs good.
55 2 door post, gasser project
69 Cadillac ElDorado
69 4x4 suburban
59 ElCamino

Some mornings, it's just not worth chewing thru the leather straps"
stevo camaro is offline  
post #9 of 10 (permalink) Old Jan 29th, 06, 12:38 AM
Senior Tech
 
Join Date: Jun 2005
Location: Sunny So. Cal
Posts: 3,064
Re: Small Problem I hope?

Your idle is way too fast......That is why you have run-on. Let your engine warm up and adjust it to specs. I'm not sure what the specs are for your engine, but it shouldn't be above 800 RPM.

67 RS Camaro 327/ 350 Holley 650cfm > Edelbrock Performer Intake > Pertronix Ignition > Accel Super Stock Coil and Wires > Hedman Hedders > Hotchkis Performance Springs > 15" Rallys all around


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
Camaro buds until the end!!!
Camaro Dave is offline  
post #10 of 10 (permalink) Old Jan 29th, 06, 05:53 AM
Gold Lifetime Member
Harry
 
dawg's Avatar
 
Join Date: Mar 2004
Location: Colebrook CT.
Posts: 4,020
Re: Small Problem I hope?

recheck your settings timing etc.
you did retorque your intake and heads after a few runs didnt you????????
if not you have a huge vacum leak.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

434 stroker
US Navy retired

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
dawg is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Team Camaro Tech forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address.
NOTE we receive a lot of registrations with bad email addresses. IF you do not receive your confirmation email you will not be able to post. contact support and we will try and help.
Be sure you enter a valid email address and check your spam folder as well.



Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome