'94 Z28 acting like a Ford - Team Camaro Tech
Troubleshooting Diagnosing problems done here.

 
LinkBack Thread Tools Display Modes
post #1 of 7 (permalink) Old Feb 4th, 06, 12:02 PM Thread Starter
 
Join Date: Feb 2006
Posts: 3
Exclamation '94 Z28 acting like a Ford

I was wondering if anybody knew what might be going on with my car. I have a '94 Z28, and it died on me last night. It was running fine, until I accelerated from an intersection. It died about halfway through. I pulled over, and tried restarting. I got a little dieseling and about 100-300 rpms for a second, then nothing. The car won't even turn over now. The starter works, and all fluids are new in the car. Can anybody help?
txgi213 is offline  
Sponsored Links
Advertisement
 
post #2 of 7 (permalink) Old Feb 4th, 06, 04:04 PM
 
Join Date: Jan 2006
Posts: 24
Re: '94 Z28 acting like a Ford

this responce may sound stupid but have you checked the fuse for the fuelpump it sounds like a fuel problem. did it die hard or kind of choke up?
miami79 is offline  
post #3 of 7 (permalink) Old Feb 4th, 06, 07:47 PM Thread Starter
 
Join Date: Feb 2006
Posts: 3
Lightbulb Re: '94 Z28 acting like a Ford

It died softly, with a little sputtering. I checked all the fuses and relays today. They were fine. I also ran carb cleaner through a vacuum line to rule out fuel problems. I am starting to think coil or distributor.
txgi213 is offline  
 
post #4 of 7 (permalink) Old Feb 5th, 06, 08:56 AM
 
Join Date: Dec 2005
Posts: 16
Re: '94 Z28 acting like a Ford

Quote:
Originally Posted by txgi213
It died softly, with a little sputtering. I checked all the fuses and relays today. They were fine. I also ran carb cleaner through a vacuum line to rule out fuel problems. I am starting to think coil or distributor.
well your car does not have a "distributor" per say. It has a optispark it is mounted in the front of the engine just below the water pump. Very common for this to fail any where form 75k miles and up. expensive job for a shop to do $800- $1000. get your codes checked on the car. got to shbox.com or LT1TECH.com for more info if you attempt to do this yourself
T'S 95T/A is offline  
post #5 of 7 (permalink) Old Feb 6th, 06, 10:39 AM Thread Starter
 
Join Date: Feb 2006
Posts: 3
Re: '94 Z28 acting like a Ford

It seems to be the optispark. The water pump is leaking coolant onto the unit. I had this water pump replaced less than a year ago. Kinda pisses me off. The optispark was replaced 2 years ago as well.
txgi213 is offline  
post #6 of 7 (permalink) Old Feb 7th, 06, 08:42 AM
 
Join Date: Dec 2005
Posts: 16
Re: '94 Z28 acting like a Ford

if I were you and was going to keep the car for awhile, I would upgrade to a 95+ and up optispark because it is vented. It will keep the moisture out of it from the road or your waterpump. My guess is that if this was done the first time you replaced it you would not be replacing it again. good luck are you gonig to do this work yourself?
T'S 95T/A is offline  
post #7 of 7 (permalink) Old Jul 24th, 06, 07:04 AM
 
Join Date: May 2005
Posts: 8
Re: '94 Z28 acting like a Ford

the 94 optispark has a splined hole for a splined shaft. the 95 and up have a shaft already made on to the optispark. how do you convert??also how do you check an optispark to see if its going bad (some times). mine will crank up right now and run fine, but after driving about 10-15 miles it startes running real rough , deiseling and then goes dead. wont start. it will turn over but wont start. then after a wait of any where from 5 min to 2 hours it will start right up and run great for another 10-15 miles...
prostreet is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Team Camaro Tech forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address.
NOTE we receive a lot of registrations with bad email addresses. IF you do not receive your confirmation email you will not be able to post. contact support and we will try and help.
Be sure you enter a valid email address and check your spam folder as well.



Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome