Broken Fan Belt - Team Camaro Tech
Troubleshooting Diagnosing problems done here.

 
LinkBack Thread Tools Display Modes
post #1 of 3 (permalink) Old Feb 19th, 06, 06:47 PM Thread Starter
 
Join Date: Oct 2005
Posts: 40
Broken Fan Belt

The fan belt in my 69 broke resently while driving down the highway. I noticed the gen. light come on, thought it was my alt. going bad. About 2 min. later I noticed my temp gauge pegged! I pulled off the road as soon as possible, but don't know how long it was actually overheating. I've checked the oil (no water), and the water (no oil). Is there anything else I should check? What kind of damage could have been done? Anything I should worry about?
Dan 69 is offline  
Sponsored Links
Advertisement
 
post #2 of 3 (permalink) Old Feb 19th, 06, 06:59 PM
Senior Tech
Scott
 
Join Date: Apr 2005
Location: CA
Posts: 239
Re: Broken Fan Belt

If you have only one fan belt, the belt also drives the water pump and fan. Losing the belt will cause an overheat in short order.

You have already checked the obvious problem areas. Replace the belt, fill it with coolant, and see what happens. If there is any damage, it will reveal itself very soon. If it runs OK and keeps its cool, consider yourself lucky.
red67camaro is offline  
post #3 of 3 (permalink) Old Feb 19th, 06, 07:26 PM
Senior Tech
 
Join Date: Jun 2005
Location: Sunny So. Cal
Posts: 3,064
Re: Broken Fan Belt

Chances are slim to none that there is any engine damage, since you pulled over right away. You probably noticed the temperature gauge go up after you stopped. The car actually gets hotter when you stop rather than when you are moving.

67 RS Camaro 327/ 350 Holley 650cfm > Edelbrock Performer Intake > Pertronix Ignition > Accel Super Stock Coil and Wires > Hedman Hedders > Hotchkis Performance Springs > 15" Rallys all around


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
Camaro buds until the end!!!
Camaro Dave is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Team Camaro Tech forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address.
NOTE we receive a lot of registrations with bad email addresses. IF you do not receive your confirmation email you will not be able to post. contact support and we will try and help.
Be sure you enter a valid email address and check your spam folder as well.



Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome