94 3.4l v6 5 speed camaro - Team Camaro Tech
Troubleshooting Diagnosing problems done here.

 
LinkBack Thread Tools Display Modes
post #1 of 2 (permalink) Old Mar 21st, 06, 08:00 AM Thread Starter
 
Join Date: Mar 2006
Posts: 1
94 3.4l v6 5 speed camaro

what could be causing these problems hesatatoin,lacks power,and we have had it in the shop they have replaced the injecters with accel 17lb injecters,replaced the PCM,crank and cam sensors,coil packs, plugs and wires and checked the wiring harness;still did not run right after it came from the shop.We checked the new spark plugs and one was cracked. we replaced it and it ran good for 2 days then ran the same as before.and when ran hard it sometimes blows a plug wire off.any ideas?
elizabeth trende is offline  
Sponsored Links
Advertisement
 
post #2 of 2 (permalink) Old Mar 21st, 06, 08:42 AM
Senior Tech
Steven
 
Join Date: Jan 2001
Location: Raleigh, NC
Posts: 1,046
Re: 94 3.4l v6 5 speed camaro

Some ideas ... I see no mention of fuel supply like fuel filter and/or fuel pump to insure that you are getting adequate fuel supply... Also check air intake for clean filter and to insure that there is no obstruction there... A clogged cat/exhaust will also give you problems and kill power ... Lastly, check connectors on sensors to see if something may be getting intermittent/faulty signal ... Hard to come up with reason why plug wire blows off ...maybe th end needs to be "squeezed" a little for a tighter fit ...
sdtsdt is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Team Camaro Tech forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address.
NOTE we receive a lot of registrations with bad email addresses. IF you do not receive your confirmation email you will not be able to post. contact support and we will try and help.
Be sure you enter a valid email address and check your spam folder as well.



Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome