I should have taken courses.... - Team Camaro Tech
Troubleshooting Diagnosing problems done here.

 
LinkBack Thread Tools Display Modes
post #1 of 6 (permalink) Old Mar 24th, 06, 04:34 PM Thread Starter
Senior Tech
Keith
 
Join Date: Feb 2006
Location: Manchester, NJ
Posts: 252
Send a message via AIM to heatsinker
I should have taken courses....

Ok, bought the car like 3-4 weeks ago and all was great. Suddenly I jump in to go for a drive and........click/click nothing. Try a jumpstart and after a long time she finally turns over. Let it run a while, shut it off and nothing again. I am thinking battery or altenator.........sound right?

Keith
1967 L-35 SS

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
heatsinker is offline  
Sponsored Links
Advertisement
 
post #2 of 6 (permalink) Old Mar 24th, 06, 04:57 PM
 
Join Date: Jun 2004
Posts: 88
Re: I should have taken courses....

It sounds like the battery has gone fatally dead. You can take the battery in to a parts store and have it tested. If you jumpstart the car, take off the cables and it continues to run fine, it sounds like the charging system is working fine. Take a multimeter or look at your volt guage if you have one, it should read 13-14 volts if the alternator is good. Less than 12 volts and it is bad.
SoCalFirstGen is offline  
post #3 of 6 (permalink) Old Mar 24th, 06, 05:00 PM Thread Starter
Senior Tech
Keith
 
Join Date: Feb 2006
Location: Manchester, NJ
Posts: 252
Send a message via AIM to heatsinker
Re: I should have taken courses....

thanks

Keith
1967 L-35 SS

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
heatsinker is offline  
 
post #4 of 6 (permalink) Old Mar 25th, 06, 07:06 AM Thread Starter
Senior Tech
Keith
 
Join Date: Feb 2006
Location: Manchester, NJ
Posts: 252
Send a message via AIM to heatsinker
Re: I should have taken courses....

Thanks again........Bought Battery and altenator, Installed battery and tried it, started no problem. Guess I now have a spare altenator if it ever goes bad.

thanks again,

Keith

Keith
1967 L-35 SS

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
heatsinker is offline  
post #5 of 6 (permalink) Old Mar 25th, 06, 02:03 PM
Senior Tech
Steps
 
Join Date: Dec 2005
Location: New Zealand
Posts: 13,316
Re: I should have taken courses....

Get a hydrometer...couple bucks at the local store...check SG in each battery cell, if 1 or 2 cells are markedly diff to the rest...replace battery.
At the same time check alternater out puts...just to make sure it wasnt the alternator that killed the battery.

My Spelling is not incorrect...it is creative

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
Steptoe is offline  
post #6 of 6 (permalink) Old Mar 25th, 06, 07:17 PM
Senior Tech
 
Join Date: Mar 2002
Location: Austin, TX, USA
Posts: 5,277
Re: I should have taken courses....

Check out the thread https://www.camaros.net/forums/showthread.php?t=77517 titled "I don't really know whats hapeening!". I posted a general proof of performance you can do to identify charging / battery problems.

Dave
========================
68 Coupe, 350 w/ Edelbrock Performer RPM heads, cam, intake, 700R4, Dave's small body HEI
dnult is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Team Camaro Tech forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address.
NOTE we receive a lot of registrations with bad email addresses. IF you do not receive your confirmation email you will not be able to post. contact support and we will try and help.
Be sure you enter a valid email address and check your spam folder as well.



Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome