92 rs tbi no power above 1/4 throttle - Team Camaro Tech
Troubleshooting Diagnosing problems done here.

 
LinkBack Thread Tools Display Modes
post #1 of 3 (permalink) Old Mar 26th, 06, 11:18 AM Thread Starter
 
Join Date: Mar 2006
Posts: 14
92 rs tbi no power above 1/4 throttle

i just rescued a 92 rs 305 5-speed from a backyard after it sat for a year or so and got it running last week after replacing fuel pump/filter + battery and alt. the car ran great for a while, then the power started to drop off. Now i cant even get it down the road. under load, anytime i open the throttle past 1500 rpm the car stumbles and totally loses all power. if i hold my foot to the floor with no load, it reads 2500 rpm or so, but the engine is barely running, and sounds like the compressor in my garage.when its not under load, i can rev it to about 2300 with very light throttle, but not passt 1/4 or so. if i keep a flow of throttle cleaner into the throttles, it gets a little better, but still sucks, somebody help, please
rs92s1088 is offline  
Sponsored Links
Advertisement
 
post #2 of 3 (permalink) Old Apr 6th, 06, 05:55 AM
Senior Tech
Darrell
 
Join Date: Mar 2006
Location: powell, wyoming
Posts: 392
Re: 92 rs tbi no power above 1/4 throttle

i would start with a fuel press. test
Seneca SS is offline  
post #3 of 3 (permalink) Old Apr 13th, 06, 12:43 PM
Senior Tech
Dave
 
Join Date: Oct 2005
Location: Rhode Island
Posts: 1,356
Re: 92 rs tbi no power above 1/4 throttle

Did you replace the old gas? If not, then that's probably the problem. Also, maybe try another fuel filter, as gum deposits from old gas may have plugged up the new one you said you installed.

Plugged cat converter will act same way.

Kinda sounds like fuel delivery or plugged cat to me..................

-

Dave F. in Rhode Island
'68 Camaro SS Accel DFI 454 (SOLD - I'm a boring Corvette owner now)
Bought my first big-block Chevy in 1970
Chevy-SS is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Team Camaro Tech forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address.
NOTE we receive a lot of registrations with bad email addresses. IF you do not receive your confirmation email you will not be able to post. contact support and we will try and help.
Be sure you enter a valid email address and check your spam folder as well.



Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome