1969 camaro clutch pedal - Team Camaro Tech
Troubleshooting Diagnosing problems done here.

 
LinkBack Thread Tools Display Modes
post #1 of 4 (permalink) Old Apr 5th, 06, 04:52 AM Thread Starter
Tech Team
 
Join Date: Feb 2006
Posts: 54
1969 camaro clutch pedal

How do I tell on a used clutch pedal setup I am looking at if it is for a 1969 camaro or for the 67-68 camaro? I have heard they are different? Is it the hole locations in them? Thanks for any help
Spirit1 is offline  
Sponsored Links
Advertisement
 
post #2 of 4 (permalink) Old Apr 5th, 06, 06:55 AM
Senior Tech
Charles
 
Join Date: May 2004
Location: kansas city, mo
Posts: 768
Re: 1969 camaro clutch pedal

on top of the pedal bracket there should be a date code stamped into the metal. at least there was for the 2 69' set-ups i had.

BELIEVE IN YOUR DREAMS
1969 SS X55 NOR added RS all NOS sheetmetal, ground up resto. 24 year project and dream. optioned out the wazoo. in one thousand pieces, and coming together finally.
Run269 is offline  
post #3 of 4 (permalink) Old Apr 5th, 06, 08:06 AM
Senior Tech
 
Join Date: May 2004
Location: Southeast PA
Posts: 8,303
Re: 1969 camaro clutch pedal

The clutch pedal is the same all three years. The mounting bracket and the brake pedal are what's different 67-68 and 69. If you have an existing 69 mounting bracket in good shape, they are the same whether the car is manual or automatic. You just slip out the auto brake pedal and slide in the two pedals.

Rick's online catalog ( www.firstgen.com ) should have some good pictures of the bracket and pedals.

If you're swap meet hunting, yes the date is stamped in the top.

Eric
69 'vert project big block/TKO 600 RR
68 'vert driver RS clone -- gone!
Eric Kammerer is offline  
 
post #4 of 4 (permalink) Old Apr 5th, 06, 08:24 AM Thread Starter
Tech Team
 
Join Date: Feb 2006
Posts: 54
Re: 1969 camaro clutch pedal

Thanks for the help! I have a automatic pedal in my car now. What is different on the clutch/brake pedal?
I just noticed Rick's sells a brake clutch pedal for 67-68 and a seprate set up for a 69.
Spirit1 is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Team Camaro Tech forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address.
NOTE we receive a lot of registrations with bad email addresses. IF you do not receive your confirmation email you will not be able to post. contact support and we will try and help.
Be sure you enter a valid email address and check your spam folder as well.



Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome