fuel delivery problem - Team Camaro Tech
Troubleshooting Diagnosing problems done here.

 
LinkBack Thread Tools Display Modes
post #1 of 4 (permalink) Old Apr 9th, 06, 10:27 AM Thread Starter
 
Join Date: Apr 2006
Posts: 6
fuel delivery problem

i have a 91 5 speed, 305 tbi. i am getting no fuel to the injection system. i replaced the fuel pump, filter and fuel relay switch. i am getting no power to the pump. any suggestions?
91 5stbi is offline  
Sponsored Links
Advertisement
 
post #2 of 4 (permalink) Old Apr 10th, 06, 03:47 AM
Super Moderator
Bess-68's rule
 
Everett#2390's Avatar
 
Join Date: Sep 2000
Location: Va Beach VA
Posts: 31,626
Garage
Re: fuel delivery problem

Empty tank.
Blown fuse.
Open power supply wire in harness.
Open ground wire/circuit at fuel pump assembly/tank.
Sunken socket in connector(s).
No power to relay due to broken wire or bad driver in ECM.
Fusible link at starter solenoid stud burnt/broken.

Fuel pump should come ON for two seconds when ign ke is turned to IGN position. After this event, Start signal should energize the relay, via ECM, and, in a parallel path, oil pressure switch should close and provide another path to energize fuel pump. Oil pressure sensor is underneath distributor.

Give a man a rescued dog for the health of both their souls. May 2017 ROTM Winner - Thank you!
'
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
CUBS - 2016 World Series Champions - maybe this year, 2019 ...
Everett#2390 is offline  
post #3 of 4 (permalink) Old Apr 10th, 06, 05:48 PM
Senior Tech
Darrell
 
Join Date: Mar 2006
Location: powell, wyoming
Posts: 392
Re: fuel delivery problem

when you turn ign.on pump should get power for about 3 seconds,if not ck pump relay
Seneca SS is offline  
 
post #4 of 4 (permalink) Old Apr 15th, 06, 10:10 AM Thread Starter
 
Join Date: Apr 2006
Posts: 6
Re: fuel delivery problem

i heard that if my oil pressure sensor was faulty that my fuel pump would not energize. is that true?
91 5stbi is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Team Camaro Tech forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address.
NOTE we receive a lot of registrations with bad email addresses. IF you do not receive your confirmation email you will not be able to post. contact support and we will try and help.
Be sure you enter a valid email address and check your spam folder as well.



Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
Edelbrock carb problem? fuel drip, hesitation and backfire -please HELP! mr69 Troubleshooting 6 Aug 7th, 11 07:06 PM
Autometer Fuel Gage Problem jacket Electrical & Wiring 4 Nov 6th, 05 02:42 PM
fuel tank or gauge problem? norcalcamaro Engine 3 Oct 28th, 05 09:09 AM
fuel pressure problem camaro man Engine 21 Jul 20th, 05 05:07 PM
Fuel Injection problem Leviathan Engine 3 Aug 30th, 04 01:38 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome