Cowl Induction Problems - Team Camaro Tech
Troubleshooting Diagnosing problems done here.

 
LinkBack Thread Tools Display Modes
post #1 of 4 (permalink) Old May 16th, 06, 08:46 PM Thread Starter
Tech Team
 
Join Date: Sep 2005
Posts: 61
Unhappy Cowl Induction Problems

Hey Guys, Can anybody help me???? Installed new cowl induction on my 69 Z Iam not getting the solenoid to work? The relay clicks when you push on the detent switch, but the solenoid does not open the flapper? I tested the solenoid with 12 volts direct to it, and it works and opens fine, What am I over looking??? Thanks if you can help!!!!!!!!!! Jimi302z28s
jimi302z28s is offline  
Sponsored Links
Advertisement
 
post #2 of 4 (permalink) Old May 17th, 06, 03:14 AM
Senior Tech
Steve
 
Join Date: Jun 2005
Location: central New York
Posts: 1,644
Re: Cowl Induction Problems

I had the same problem. Mine had a bad relay. It's the one that's fastened to the firewall. The flapper would open when it was jumpered with hot wire. Replaced the relay and works fine now. Also make sure you're getting a good connection at the plug-in on the hood. Good luck!

1969 Z28

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

1969 Firebird 400

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

My new project for 2010 DONE/ Sold.

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

2002 Camaro SS LE/SLP
67 Nova SS 327, M20, 3.73
nashcar is offline  
post #3 of 4 (permalink) Old May 17th, 06, 04:14 AM
Senior Tech
Mike
 
Join Date: Apr 2004
Location: North Canton, Ohio
Posts: 179
Wink Re: Cowl Induction Problems

Quote:
Originally Posted by jimi302z28s
Hey Guys, Can anybody help me???? Installed new cowl induction on my 69 Z Iam not getting the solenoid to work? The relay clicks when you push on the detent switch, but the solenoid does not open the flapper? I tested the solenoid with 12 volts direct to it, and it works and opens fine, What am I over looking??? Thanks if you can help!!!!!!!!!! Jimi302z28s
Make sure the solenoid is grounded good, Did you paint the solenoid or the bracket??? If you look at a original bracket ther is a small dimple that is supposed to bit into the solenoid body and supply the ground.
Take a jumper from the solenoid to a ground strap and try that first. I have seen this several times.
m22mike is offline  
 
post #4 of 4 (permalink) Old May 17th, 06, 05:20 PM Thread Starter
Tech Team
 
Join Date: Sep 2005
Posts: 61
Thumbs up Re: Cowl Induction Problems

Hey I didnot have it grounded!!! problem solved! Thanks for the help!! M22mike! Jimi
jimi302z28s is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Team Camaro Tech forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address.
NOTE we receive a lot of registrations with bad email addresses. IF you do not receive your confirmation email you will not be able to post. contact support and we will try and help.
Be sure you enter a valid email address and check your spam folder as well.



Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
What is Cowl Induction? Alfonso Perez Performance 31 Nov 29th, 10 09:50 AM
Cowl induction base 40Coupe Performance 1 Dec 17th, 05 01:05 PM
4 inch cowl induction pics wanted CanCamaro Body Shop 7 Dec 16th, 05 10:30 PM
cowl induction vs. ram air timemachiness Performance 9 Sep 6th, 01 01:35 PM
Cowl induction GregSS396 Tech 2000 4 May 5th, 01 05:53 AM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome