69 alignment problem - Team Camaro Tech
Troubleshooting Diagnosing problems done here.

 
LinkBack Thread Tools Display Modes
post #1 of 2 (permalink) Old May 21st, 06, 01:13 PM Thread Starter
 
Join Date: May 2006
Posts: 140
69 alignment problem

I have a 69 camaro that has a major alignment problem. The bottom of the front wheels bow in causing the tie rod arms to rub up against the tires. My fear was that it was a bent frame, but I took it to an local alignment shop and he said he was able to get it into alignment but a soon as he would take it for a spin in would fall back out of alignment. He said the bushing were pretty worn out but that it would cause it to do that. He also looked under the car and noticed nothing bent or unusual that would caused the problem. Im someone has maybe been through something similar or someone who knows more could shed some light on what the problem could possible be.
smattix is offline  
Sponsored Links
Advertisement
 
post #2 of 2 (permalink) Old May 21st, 06, 06:43 PM
Team Member
John
 
JohnZ's Avatar
 
Join Date: Sep 2000
Location: Washington, Michigan USA
Posts: 7,728
Re: 69 alignment problem

If the tie rod ends are touching the tires, it has the wrong wheels on it; the relationship between the tie rod ends and the spindles is fixed, and isn't affected in any way by alignment. If it lost the alignment settings when driven, the upper and lower control arm bushings are probably shot and need to be replaced.


JohnZ
CRG
JohnZ is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Team Camaro Tech forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address.
NOTE we receive a lot of registrations with bad email addresses. IF you do not receive your confirmation email you will not be able to post. contact support and we will try and help.
Be sure you enter a valid email address and check your spam folder as well.



Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
Gonna fix a 69 dreamweaver Bench Racing 31 Jul 23rd, 06 07:18 PM
Q-Jet Problem LukeWarm Troubleshooting 7 Apr 22nd, 06 10:43 AM
Weird Vibration Problem Cameron Brakes, Suspension & Steering 11 Apr 19th, 06 07:18 AM
69 Rear Side Window Fuzzy Problem, Help! Buildinga55 Body Shop 3 Mar 7th, 06 02:57 PM
weird starting problem matth Electrical & Wiring 2 Mar 10th, 02 05:35 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome