Power Problem - Team Camaro Tech
Troubleshooting Diagnosing problems done here.

 
LinkBack Thread Tools Display Modes
post #1 of 4 (permalink) Old May 29th, 06, 05:35 PM Thread Starter
 
Join Date: May 2006
Posts: 7
Angry Power Problem

I have a 1993 Chev Camaro RS (V8). It has a problem with air on or lights on, it cuts off while I am driving, but as soon as I turn air or lights off, it comes right back on without restarting car, could this be an alternator problem? It seems to be an alternator or battery but they both check out fine. Could there be voltage regulator on this model. Also this occurs when the radio is on. Any help appreciated. The motor /horsepower are fine. The "check engine soon" light comes on right before it cuts off.
AnneSimpson is offline  
Sponsored Links
Advertisement
 
post #2 of 4 (permalink) Old May 29th, 06, 08:32 PM
Senior Tech
Darrell
 
Join Date: Mar 2006
Location: powell, wyoming
Posts: 392
Re: Power Problem

sounds like alt.,ck voltage while running2500 rpm should be 14.2 -15.5 if in that range alt.is ok
Seneca SS is offline  
post #3 of 4 (permalink) Old May 30th, 06, 01:36 AM
Senior Tech
 
Join Date: Jun 2005
Location: Sunny So. Cal
Posts: 3,064
Re: Power Problem

Find out if there are any trouble codes in the ECM that might shed some light on to what the problem is. When you start the car, does the idle go up to around 2500 RPM and gradually drop to around 800 rpms? You might have a IAC (Idle air control) problem.

67 RS Camaro 327/ 350 Holley 650cfm > Edelbrock Performer Intake > Pertronix Ignition > Accel Super Stock Coil and Wires > Hedman Hedders > Hotchkis Performance Springs > 15" Rallys all around


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
Camaro buds until the end!!!
Camaro Dave is offline  
 
post #4 of 4 (permalink) Old May 30th, 06, 05:16 AM
Senior Tech
Dave
 
Join Date: Oct 2005
Location: Rhode Island
Posts: 1,356
Re: Power Problem

I would start by cleaning wiring connections and looking for broken or loose ground wires (or any wires that are broken/loose).

Electrical gremlins are often caused by bad grounding, frayed wires, bad connector, etc..................


-

Dave F. in Rhode Island
'68 Camaro SS Accel DFI 454 (SOLD - I'm a boring Corvette owner now)
Bought my first big-block Chevy in 1970
Chevy-SS is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Team Camaro Tech forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address.
NOTE we receive a lot of registrations with bad email addresses. IF you do not receive your confirmation email you will not be able to post. contact support and we will try and help.
Be sure you enter a valid email address and check your spam folder as well.



Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
overlap, and stock idle L79Mike Performance 13 Jan 21st, 06 09:23 PM
Power Problem Sixty-Seven rs Electrical & Wiring 4 Apr 8th, 04 04:53 AM
power lock actuator problem .... 73LT1M6 Electrical & Wiring 3 Oct 23rd, 02 05:17 AM
Power antenna problem 69vert Electrical & Wiring 2 May 5th, 02 05:33 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome