88 2.8L V6 FI Dies on idle - Team Camaro Tech
Troubleshooting Diagnosing problems done here.

 
LinkBack Thread Tools Display Modes
post #1 of 5 (permalink) Old Jun 6th, 06, 10:29 AM Thread Starter
 
Join Date: Jun 2006
Posts: 4
88 2.8L V6 FI Dies on idle

I have an 88 Chevy Camaro Sport Coupe. It's a 2.8 litre V6 multi port fuel injected. I've had her since she was new and I take fairly good care of her.

I went to start her yesterday and all it would do is crank as though it wasn't getting any gas. So I tried giving it a little gas, normally I don't have to as the car usually gives it just enough to start it but this time it wasn't. So after I gave her some gas she rolled right over. When I took my foot off the gas she choked right out. If it was a carb I'd think something just broke loose but I can see nothing loose and I'm sorta lost when it comes to electronics. If anyone could give me an idea of what I'm looking at so I have an idea if this is something I can replace myself or do I need to get my mechanic in on it. I trust him but as I'm seriously short on funds I'd rather handle it myself if I can. I've replaced water pump and alternator as well as tuned her up so I'm not a total weenie.

I appreciate any and all advice.

Thanks
Kirgan
Saugerties, NY
Kirgan is offline  
Sponsored Links
Advertisement
 
post #2 of 5 (permalink) Old Jun 6th, 06, 11:44 AM
Senior Tech
 
Join Date: Jun 2005
Location: Sunny So. Cal
Posts: 3,064
Re: 88 2.8L V6 FI Dies on idle

Check your fuel pump. Do you hear it working? You shouldn't have to pump the gas pedal on a fuel injected car.

67 RS Camaro 327/ 350 Holley 650cfm > Edelbrock Performer Intake > Pertronix Ignition > Accel Super Stock Coil and Wires > Hedman Hedders > Hotchkis Performance Springs > 15" Rallys all around


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
Camaro buds until the end!!!
Camaro Dave is offline  
post #3 of 5 (permalink) Old Jun 6th, 06, 12:16 PM Thread Starter
 
Join Date: Jun 2006
Posts: 4
Re: 88 2.8L V6 FI Dies on idle

I'm certainly no expert, I'm not even an amateur but if the fuel pump wasn't working wouldn't it not run at all? The car does run when I have my foot on the gas. It's only when I let my foot off the gas that she then dies out. With a carb I could see about just using a screwdriver to up the idle speed but in this case it's as though whatever was telling the engine how much gas it needs at rest simply isn't sending those signals anymore. Nothing else is different about the car. When I start her up, she does run rougher than normal for a bit but then calms down a bit once she's been going for a minute or so. I traced every line that I could see under the hood and there are no breaks, or leaks of any kind. I'm really at a loss here.
Kirgan is offline  
 
post #4 of 5 (permalink) Old Jun 6th, 06, 01:59 PM
Senior Tech
Steven
 
Join Date: Jan 2001
Location: Raleigh, NC
Posts: 1,046
Re: 88 2.8L V6 FI Dies on idle

Grab a Haynes manual, maybe $15 bucks or so ... Some speculation ... Maybe a bad throttle position sensor ... Pressing accelerator pedal also allows more air flow ... Make sure intake and air fliter are not obstructed ..

Hey, I lived in Kingston many years ago ... right down the street, huh???
sdtsdt is offline  
post #5 of 5 (permalink) Old Jun 7th, 06, 04:39 PM
 
Join Date: Jun 2006
Posts: 3
Re: 88 2.8L V6 FI Dies on idle

try some fuel injection cleaner.never know.give that a try.i had a old 92 taurus and when ever it did that some trusty fuel injection cleaner would do the trick.
scotty2hottie93 is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Team Camaro Tech forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address.
NOTE we receive a lot of registrations with bad email addresses. IF you do not receive your confirmation email you will not be able to post. contact support and we will try and help.
Be sure you enter a valid email address and check your spam folder as well.



Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
Initial timing setting? RRatchet Performance 4 Feb 6th, 06 09:13 AM
95 camaro 3.8 turns over but dies after idle!!! jaydog50 Troubleshooting 1 Mar 29th, 05 09:50 PM
Holley tuning? railing68 Performance 22 Feb 13th, 05 03:55 AM
Holley tuning question wizard67 Performance 22 Sep 20th, 04 04:05 PM
My 1st Big Cam/ Trying to adjust Carb/Low Vacuum PERKS67-396 Engine 20 Oct 4th, 02 09:14 AM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome