Need Help First time seeing this - Team Camaro Tech
Troubleshooting Diagnosing problems done here.

 
LinkBack Thread Tools Display Modes
post #1 of 2 (permalink) Old Jun 13th, 06, 10:51 AM Thread Starter
 
Join Date: Jun 2006
Posts: 25
Need Help First time seeing this

I have a 1971 SS Camaro with a blown 454, block is a 1973 4 bolt. This is the problem, Saturday I took the car out for a drive and the oil filter gasket failed and dumped 5 quarts of 8 on the ground before I noticed it. Luckily the engine wasn't warm yet and I was only a block from the house. I changed the filter and added oil, started the engine, same thing happened. I put a hp 2002 K & N performance filter and the same thing happened again. The oil by-pass valve in the filter adapter has been plugged for odvious reasons. Engine is using a Kellam High volume oil pump, oil pressure at gasket failure was 70 psi. Runs at 45-50 when warm. I looked at the oil adapter and it appears to be for a older canister style, does this engine need a oil filter conversion kit to work with modern oil filters, it appears that the filter doesn't seat completely to the current adapter. Engine has dual moroso crank case breathers and only blows the gasket under throttle. Any assistance is greatly appreciated.
vader2 is offline  
Sponsored Links
Advertisement
 
post #2 of 2 (permalink) Old Jun 13th, 06, 11:05 AM
Gold Lifetime Member
Jim
 
Join Date: Dec 1999
Location: Yorkville, Illinois USA
Posts: 22,121
Re: Need Help First time seeing this

isn't this an exact duplicate of a post a couple days ago?
One that did not by any means go unanserwed if I recall correctly.

Vader, perhaps in the interest of keeping the site tidy, you could delete this and add any new info to your original posting?





To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.



To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
New website for my vert is coming together. Do ya like the slide show on the home page?
JimM is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Team Camaro Tech forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address.
NOTE we receive a lot of registrations with bad email addresses. IF you do not receive your confirmation email you will not be able to post. contact support and we will try and help.
Be sure you enter a valid email address and check your spam folder as well.



Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
Hello...long time Camaro driver..first time here. OPUSONE Bench Racing 7 Mar 20th, 06 05:46 PM
Give back vacation time?????? BonzoHansen Bench Racing 21 Jan 7th, 06 11:14 AM
best new time 406sbc jethro81z28 Performance 6 Nov 19th, 03 01:52 AM
Harbor Freight Chop Saw Scooby Doo Body Shop 10 Dec 22nd, 02 04:48 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome