89 Camaro IROC 5.0 won't start - Team Camaro Tech
Troubleshooting Diagnosing problems done here.

 
LinkBack Thread Tools Display Modes
post #1 of 3 (permalink) Old Jun 17th, 06, 03:12 PM Thread Starter
 
Join Date: Jun 2006
Posts: 1
Unhappy 89 Camaro IROC 5.0 won't start

Hi gang,

5.0 Tune Port fuel injection won't start. Distributor was fried. I replaced it, then did the catalytic converter, spark plugs, fuel pump, and starter. Ran okay, but idled rough - needs 3 fuel injectors, 2 are weak, reading in single digits, the last is reading 11 - but the motor doesn't seem to be getting fuel. Fuel pump is working. Pressure regulator? Could the bad injectors have just locked up?

Some advice on where to go next would be great. Thanks in advance.
Jimbosaurus is offline  
Sponsored Links
Advertisement
 
post #2 of 3 (permalink) Old Jul 1st, 06, 07:43 PM
 
Join Date: Jan 2006
Posts: 12
Re: 89 Camaro IROC 5.0 won't start

I would replace the bad injectors. If you still have the problem I would replace the in-line fuel filter. It should be under the car about middle way's. Good luck, hope you get the problem fixed soon. Todd
fasthotrodtodd is offline  
post #3 of 3 (permalink) Old Jul 1st, 06, 08:10 PM
Senior Tech
Don
 
ZZ_430's Avatar
 
Join Date: May 2001
Location: Houston, Texas
Posts: 4,491
Re: 89 Camaro IROC 5.0 won't start

What's the fuel pressure reading?

Don ~ TC Member #15 ~
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


Don't mess with Texas!
ZZ_430 is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Team Camaro Tech forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address.
NOTE we receive a lot of registrations with bad email addresses. IF you do not receive your confirmation email you will not be able to post. contact support and we will try and help.
Be sure you enter a valid email address and check your spam folder as well.



Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
My 2 cents on the new Camaro...gotta say it clill Fifth Generation 77 Oct 24th, 06 06:28 PM
68 camaro won't start!!! jheabs Troubleshooting 4 Feb 19th, 06 07:20 PM
92 Camaro 5.0 TBI - Shutting off Problems Mongo0se Troubleshooting 8 Jan 11th, 06 05:56 PM
68 Camaro refuses to start rodsters Troubleshooting 1 Jun 2nd, 02 12:08 PM
My camaro won't start Broden89rs Tech 2000 5 Sep 27th, 00 02:42 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome