Someone Help me please! Speedometer is evil - Team Camaro Tech
Troubleshooting Diagnosing problems done here.

 
LinkBack Thread Tools Display Modes
post #1 of 3 (permalink) Old Jul 29th, 06, 05:11 PM Thread Starter
 
Join Date: Jul 2006
Posts: 2
Unhappy Someone Help me please! Speedometer is evil

I recently purchased a 1967 Camaro. It is my pride and joy now, but I can't drive it. It drives great, but the Speedometer isn't moving at all, I have no idea if it's broken or if it just isn't connected. I was wondering if some one knows where to get a step by step guide for hooking up the speedometer, I have no experience with this stuff and I would like to gain some. Also if anyone has any ideas about the drivers seat. Im only 5 ft tall, so I have problems switching gears with the way the seats are made, but I don't want to have to take out the seats unless there is no other way. I didn't think it would be much of a problem, but, it is. I am sorry if it is posted somewhere, I had no luck finding it. Thanks! ^_^

Also, here is a picture of my baby. I can't wait till I can repaint it since it has a few flaws right now, but it's still beautiful
http://img93.imageshack.us/img93/3839/newcamaroug6.jpg

Last edited by k9qthandler; Jul 29th, 06 at 05:42 PM.
k9qthandler is offline  
Sponsored Links
Advertisement
 
post #2 of 3 (permalink) Old Jul 29th, 06, 05:30 PM
Gold Lifetime Member
Jim
 
Join Date: Dec 1999
Location: Yorkville, Illinois USA
Posts: 22,121
Re: Someone Help me please! Speedometer is evil

very nice car, and welcome to Team Camaro!

First thing you need is information. Go to any of the restoration parts houses, http://www.386.com http://www.firstgen.com http://www.drclassic.com are a few. Go to the publications section and pick up some books. The first 2 would be the Assembly manual and the Fisher body service manual. You might also pick up a book or 2 on general camaro restoration, they are easier to deal with than the GM manuals sometimes.

The speedo is most likely a problem with the cable. It attaches to the transmission, goes through the firewall, and into the back of the speedo. It's probably disconnected, or the inner part of the cable is broken.

IT is possible to rig extenders on the seat mounts to move them further forward.





To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.



To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
New website for my vert is coming together. Do ya like the slide show on the home page?
JimM is offline  
post #3 of 3 (permalink) Old Jul 29th, 06, 05:42 PM Thread Starter
 
Join Date: Jul 2006
Posts: 2
Re: Someone Help me please! Speedometer is evil

Thank you so much! Ill be sure to try that out. Thanks again!!!
k9qthandler is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Team Camaro Tech forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address.
NOTE we receive a lot of registrations with bad email addresses. IF you do not receive your confirmation email you will not be able to post. contact support and we will try and help.
Be sure you enter a valid email address and check your spam folder as well.



Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome