No power steering????????? - Team Camaro Tech
Troubleshooting Diagnosing problems done here.

 
LinkBack Thread Tools Display Modes
post #1 of 5 (permalink) Old Aug 25th, 06, 10:58 AM Thread Starter
 
Join Date: Jan 2006
Posts: 27
No power steering?????????

II just purchased this killer 68 Camaro w/ a new 396 big block, alum head, serpentine-belt driven beast 530 hp. @ the flywheel. The motor was done up with no expense spared (buy the previous owner--even better). There are billet Alum pulleys throughout the front of this engine. All components of this engine are new (no rebuilds)
The problem, I am getting no power steering at all. The "original" steering gear box is in place and shows no signs of leakage, no visual defects noted. The high pressure hose and low pressure hoses are new and installed correctly on the gear box side and the pump connection side. Yes, there is fluid in the pump-which is also new. I did mention this engine is serpentine belt driven, so the belt is on the correct side of the pump's pulley (right-side w/ clockwise rotation). However, the billet pulley is larger then the "standard" pulley, it's currently approx eight inch diameter. The belt is rotating and shows no slipping. Neither the pump nor the gear box is making any abnormal noise(s).
Question, Note, I did not install this pump, is there such a thing as the possibility of the pump being the wrong pump--different flow/rotation requirement? Can the pulley be too large and causing the improper "flow" requirements? Any ideas? This is strange.
indpthwill is offline  
Sponsored Links
Advertisement
 
post #2 of 5 (permalink) Old Aug 25th, 06, 11:58 AM
Senior Tech
 
Join Date: Jan 2004
Location: Saginaw, Michigan
Posts: 1,122
Re: No power steering?????????

If the pulley is too large, you may find that you lack power assist at idle or while parking. You will regain power assist as your engine rpms increase. This does not sound like your problem.

It sounds as if you have a pump problem. Possibly rotating in the wrong direction. Unfortunately, I do not have information on identifying a reverse rotation pump.

Jim
JIML82 is offline  
post #3 of 5 (permalink) Old Aug 25th, 06, 06:47 PM
Team Member
 
Join Date: Jun 2000
Location: LaGrange,Il
Posts: 1,026
Re: No power steering?????????

Yes! it is possible that the pump is rotating the wrong direction. There are pumps for both rotations, Serpentine running on the Vees, or running on the flat side of the belt.

It is not easy to tell which pump is which. The best I can say is disconnect the pressure line and turn the pump by hand and see if it is pumping out the line.


TTFN
Mat

SSCARGO
Mat Klemp is offline  
 
post #4 of 5 (permalink) Old Aug 27th, 06, 08:49 AM
Senior Tech
Dave
 
Join Date: Oct 2005
Location: Rhode Island
Posts: 1,356
Re: No power steering?????????

Yeah, I'll bet pump is rotating in wrong direction...........


-

Dave F. in Rhode Island
'68 Camaro SS Accel DFI 454 (SOLD - I'm a boring Corvette owner now)
Bought my first big-block Chevy in 1970
Chevy-SS is offline  
post #5 of 5 (permalink) Old Aug 27th, 06, 09:37 AM Thread Starter
 
Join Date: Jan 2006
Posts: 27
Re: No power steering?????????

I replaced the pump, we have power steering.
The pump I had taken off and replaced, is brand new, however, I think the previous owner may have operated the pump dry--for long periods of time. Maybe he burned it up????????????
Thanks for the infor.
indpthwill is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Team Camaro Tech forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address.
NOTE we receive a lot of registrations with bad email addresses. IF you do not receive your confirmation email you will not be able to post. contact support and we will try and help.
Be sure you enter a valid email address and check your spam folder as well.



Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
Power Steering And Header Clearence JAKER110 Brakes, Suspension & Steering 8 Jul 20th, 05 04:00 PM
Power steering problem after front end rebuild BC Brakes, Suspension & Steering 4 Jul 7th, 05 09:15 PM
Twitchy 3rd gen power steering box Midnight68 Brakes, Suspension & Steering 7 May 26th, 05 05:31 PM
Power steering problems!!! dustys Troubleshooting 5 Mar 10th, 00 11:26 AM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome