tranny - Team Camaro Tech
Troubleshooting Diagnosing problems done here.

 
LinkBack Thread Tools Display Modes
post #1 of 1 (permalink) Old Aug 26th, 06, 09:30 PM Thread Starter
 
Join Date: Aug 2006
Posts: 2
Question tranny

I rencently had my 6 speed tranny rebuilt on my 98 z28 but there's still a noise occuring during 3rd and 4th gears which were the problem before. the noise sounds almost like a faulty bearing but they've all been replaced. also, what oil would be best for my car? it has 140k miles
z28robert is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Team Camaro Tech forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address.
NOTE we receive a lot of registrations with bad email addresses. IF you do not receive your confirmation email you will not be able to post. contact support and we will try and help.
Be sure you enter a valid email address and check your spam folder as well.



Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
Converter / tranny deal -- good or not? Eric68 Performance 31 Oct 28th, 05 01:51 PM
Camaro 6 speed tranny t56 Camarocollecter Transmission & Driveline 2 Oct 12th, 05 02:30 PM
Did I install my tranny right DenRS Transmission & Driveline 14 Nov 21st, 04 03:41 AM
Clutch and tranny problems. Obxhokie Transmission & Driveline 6 Aug 6th, 04 12:42 AM
new tranny or rebuild? gateruner Troubleshooting 3 Feb 9th, 03 03:13 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome