95 V6 backfiring - Team Camaro Tech
Troubleshooting Diagnosing problems done here.

 
LinkBack Thread Tools Display Modes
post #1 of 1 (permalink) Old Sep 5th, 06, 03:53 PM Thread Starter
 
Join Date: Dec 2000
Location: everett,wa.
Posts: 10
Unhappy 95 V6 backfiring

1995 Camaro V6 runs like a racer when cold. But after it warms up, I assume
changing loop, it runs real lean and will not accelerate when throttle is pressed beyond easy. Also it will buck and sputter. No codes showed on analyzer, although check engine light comes on occasionally. Changed O2
sensors, no help. My wife is threatening to sell this beauty if I don't fix it soon. PLEASE HELP !!
jerry hebert is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Team Camaro Tech forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address.
NOTE we receive a lot of registrations with bad email addresses. IF you do not receive your confirmation email you will not be able to post. contact support and we will try and help.
Be sure you enter a valid email address and check your spam folder as well.



Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
Went from poping from carb to backfiring out exhuast??? Erik Beckett Troubleshooting 5 Jan 31st, 02 10:40 AM
Backfiring through the carb. Elvis636 Troubleshooting 2 Jul 26th, 01 06:22 PM
Backfiring through the carb Elvis636 Engine 15 Jul 26th, 01 09:44 AM
Backfiring through exhaust MattD Troubleshooting 3 May 22nd, 01 12:14 PM
2.8L engine backfiring Locked Troubleshooting 1 Jul 17th, 00 07:12 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome