1994 3.4L V6 Code 75 - Team Camaro Tech
Troubleshooting Diagnosing problems done here.

 
LinkBack Thread Tools Display Modes
post #1 of 4 (permalink) Old Sep 20th, 06, 10:20 AM Thread Starter
 
Join Date: Sep 2006
Posts: 5
1994 3.4L V6 Code 75

I have a 1994 camaro 3.4L V6 auto.

I have had my car for 1yr and was running great until i had alot of work things put into it ... new plugs-wires and everthing flushed brakes you name it! It just started to run like sh#t and took my car to auto zone to have the code checked that was comeing up and they say its a code 75 EGR valve sil. # 3 .. i replaced the EGR valve with a new one and still got the Code ! Hard to start when cold.. if i go to work and let it sit for 4 or 5 hours it starts hard! like a sticky valve but.. when i drive off and get upto 20mph its stops and will not come back for 3 or 4 days. The check eng. light will only come on when im slowing down from 55mph or more !!! The code came up and i replaced the wires to the EGR and still got the same thing.. i checked the wires to the PCM and all came back good! i cleaned around the PCM to get the dust out from around it! still came up with the same thing.. so i was think'n it was the PCM ? maybe !!! so i just took back the new EGR valve to save myself 300bucks so i can get a new PCM! now that i have the old EGR valve in the check eng. light has not come on! it would do it all the time when slow down from 55mph or more.. but now its doing ok... but when i go to start my car it will not start until the 2nd or 3rd time i try it !! and i can see alot of smoke come out when i start it.. but it only will start that way if it sits more then 4 or 5 hours sometimes not until the next day.. IM so lost i donno where to check!!!

Last edited by 94camaro3.4; Sep 20th, 06 at 11:06 AM.
94camaro3.4 is offline  
Sponsored Links
Advertisement
 
post #2 of 4 (permalink) Old Sep 20th, 06, 11:05 AM Thread Starter
 
Join Date: Sep 2006
Posts: 5
Re: 1994 3.4L V6 Code 75

Can anyone help?
94camaro3.4 is offline  
post #3 of 4 (permalink) Old Sep 20th, 06, 11:54 AM
Gold Lifetime Member
Robert
 
Join Date: Oct 2000
Location: Simpsonville, SC
Posts: 3,358
Re: 1994 3.4L V6 Code 75

I have a '94 3.4L and have the same issue with the SES light coming on when slowing down from highway speed. It stays on until the engine is shut off and stays off until the next trip on the highway. I have no help for you on this one as I'm trying to figure it out myself. I did want to chime in and tell you I found a place on ebay that sells used "tested" so they say PCM's for $63.00. Do a search they'll pop right up. The only question I had was if the PCM would need to be flashed for my particular car as I've heard that might be the case. I called the place from ebay and the guy couldn't really answer that question so I've held off on buying one. Might save you some bucks if you do need a PCM. I'd consider that a last result though.

Robert

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
355ci 10:1, 64cc Edelbrocks, Comp Mag 280H, Performer RPM, 700r4 (2000 stall), 3.55 posi A/C PS PDB Hotchkis

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
369ci 10.3:1, 64cc Edelbrocks, Voodoo 276/284, Performer RPM, Holley 650DP ...T56 Magnum, 3.73 Moser 12 bolt
TC member #18
rojo is offline  
 
post #4 of 4 (permalink) Old Sep 20th, 06, 04:29 PM Thread Starter
 
Join Date: Sep 2006
Posts: 5
Re: 1994 3.4L V6 Code 75

Hey thanks .. MY car is doing the same thing !!! the light wouldnt go off ... but ya i just took my car in to have it looked at for free and they told me it was the PCM and ya it has to be flashed .. but thats only 85bucks and the pcm is 198 .. so im just going to spend the 300bucks for it .. i dont trust anything from ebay.. and the part is new so.. its better if just get the new part.. my friend has the same car and he has 250,000 on it and only replaced the key. lol so.. im keep'n this car for a long time!

Thanks for the help.
94camaro3.4 is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Team Camaro Tech forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address.
NOTE we receive a lot of registrations with bad email addresses. IF you do not receive your confirmation email you will not be able to post. contact support and we will try and help.
Be sure you enter a valid email address and check your spam folder as well.



Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
1994 computer code problem Jerry Pysher Electrical & Wiring 2 Sep 20th, 06 11:11 AM
Discount Code for Rock Auto tejasrs/ss Bench Racing 6 Apr 6th, 06 05:37 AM
ROCKAUTO 5% Discount Code Brian Lewis Bench Racing 1 Mar 30th, 06 03:49 PM
1994 3.4L Camaro Cranks but won't start. Links_56 Troubleshooting 1 Feb 17th, 06 10:13 PM
Is my POR-15 working right? MY FIRST 69 Body Shop 10 Jun 29th, 03 04:31 AM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome