94 Camaro not holding charge! - Team Camaro Tech
Troubleshooting Diagnosing problems done here.

 
LinkBack Thread Tools Display Modes
post #1 of 5 (permalink) Old Oct 24th, 06, 04:31 AM Thread Starter
 
Join Date: Oct 2006
Posts: 7
94 Camaro not holding charge!

94 Camaro not holding charge!
Hello All,
Recently bought a sweet 94 Camaro and I'm having an issue with voltage. I noticed awhile back that my windows were moving slow and my lights seemed dim. While car was running I disconnected the battery figureing the alternator would keep it going but it died so I figued I needed an alternator. I replaced it and it seem good for a few days, with short trips during the day only. Then while driving with lights and wipers going the meter went to the red again. I then replaced the belt with same results. Then had battery tested and they told me it was bad so I bought a new one. I installed new battery and now alternator is making a loud whining noise and battery still is not charging. If I disconnect the top positive wire from alternator noise stops but still no charge, obvioulsy.

Anyone????? Please..............................
Ruby Red
ruby red is offline  
Sponsored Links
Advertisement
 
post #2 of 5 (permalink) Old Oct 24th, 06, 09:13 AM
Senior Tech
Mark
 
Join Date: Mar 2001
Location: Janesville, WI
Posts: 618
Re: 94 Camaro not holding charge!

Disconecting the battery while the car is running is a no no. It may cause the alt to fail.. Do you have a volt meter..? They are only a couple of bucks at the store. What is it reading at the battery while the car is off? what is the voltage while the car is running..?? while running it should read 14 or so. any less you alt is shot.

Mark
Long Gone: 1984 Z28, 1989 RS
Current : 1967 Coupe w/350, 2010 2SS

My Photobucket >>
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
dragon0123 is offline  
post #3 of 5 (permalink) Old Oct 24th, 06, 05:37 PM
Senior Tech
Dave
 
Join Date: Oct 2005
Location: Rhode Island
Posts: 1,356
Re: 94 Camaro not holding charge!

Yeah, step 1 - you need volt meter to check voltage while engine running. Should ideally be 14.7 volts, and it shouldn't drop much even with accessories on............

-

Dave F. in Rhode Island
'68 Camaro SS Accel DFI 454 (SOLD - I'm a boring Corvette owner now)
Bought my first big-block Chevy in 1970
Chevy-SS is offline  
 
post #4 of 5 (permalink) Old Nov 8th, 06, 12:33 PM
Senior Tech
Ron
 
Join Date: Nov 2006
Location: North Channel Lake Huron
Posts: 3,934
Re: 94 Camaro not holding charge!

Here's a thought - You may have a Short in the Starter's Field Coil - this will cause a no charge situation.

Z15CAM - There was a Viper in my Rear View
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

This was my 70 1/2 Z28

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
Z15CAM is offline  
post #5 of 5 (permalink) Old Nov 8th, 06, 12:50 PM
Senior Tech
Dave
 
Join Date: Oct 2005
Location: Rhode Island
Posts: 1,356
Re: 94 Camaro not holding charge!

Oops, I think the ideal voltage is around 14.0, not 14.7 as I posted above......


-

Dave F. in Rhode Island
'68 Camaro SS Accel DFI 454 (SOLD - I'm a boring Corvette owner now)
Bought my first big-block Chevy in 1970
Chevy-SS is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Team Camaro Tech forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address.
NOTE we receive a lot of registrations with bad email addresses. IF you do not receive your confirmation email you will not be able to post. contact support and we will try and help.
Be sure you enter a valid email address and check your spam folder as well.



Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
New 69 CAMARO bodies coporic Bench Racing 16 Feb 25th, 07 08:08 AM
GM Announces that Camaro will see Production sik68 Fifth Generation 16 Aug 11th, 06 08:02 AM
GM Insiders Tell Us How A Long-Awaited Dream - The New Camaro OverAnxious Fifth Generation 41 Aug 3rd, 06 05:13 PM
2004 SuperCar Reunion Labor Day weekend HawaiianCamaro Team Camaro Cruiz-Ins 1 Aug 25th, 04 08:51 PM
Rhonert Park Camaro Results Ed Ernst Bench Racing 9 Jul 11th, 01 07:59 AM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome