67 conv drivetrain questions - Team Camaro Tech
Troubleshooting Diagnosing problems done here.

 
LinkBack Thread Tools Display Modes
post #1 of 7 (permalink) Old Oct 24th, 06, 03:26 PM Thread Starter
 
Join Date: Oct 2006
Posts: 3
67 conv drivetrain questions

I have a 67 convertible, 327 (300hp), M-20 tranny, 3:07 rearend.

The car is bogging and shaking off the line. I understand that m-20 with 3:07 equals a car that is slow off the line. It has always been that way and since it is a conv and I never meant for it to be used for racing around I accepted it. Lately it is worse though and I am wondering if it is the clutch or the frame needs stiffining with sub frame connectors. Any advice on how to diagnos what is the issue? I have the stock X-brace on still.

The suspension is stock and was restored 5 years ago. I recently upgraded to OEM style power disc brakes (front only). That is all that has been done recently. The front end vibrates now when braking and under 15 mph. I think that I need to check the front bearings and possibly tighten. Maybe they have seated since I did the brake instal and new spindles. Does that sound correct after a brake/spindle upgrade?

Thanks,
David
dav_67 is offline  
Sponsored Links
Advertisement
 
post #2 of 7 (permalink) Old Oct 24th, 06, 03:42 PM
Senior Tech
Steve
 
thewebb1's Avatar
 
Join Date: Dec 2001
Location: Fergus,Ontario,Canada
Posts: 907
Re: 67 conv drivetrain questions

Bogging sounds like fuel issues. The shaking sounds like clutch. Mine shook bad until I changed rearend gears 90% disappeared. Changed clutch and remainder disappeared.
Never heard of bearings seated after install. Are the ball joints good? maybe bad tire.

67 Camaro RS350SS (already restored) 68Convertible(future project)
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

68 Coupe(restoring)On hold
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
Gave to friend.
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

67 Convertible (restoring)
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

67 Coupe(parts car for now)
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

72 Chevelle Malibu
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

2-69 Jaguar xke roadsters (appeasing the wife)


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
thewebb1 is offline  
post #3 of 7 (permalink) Old Oct 24th, 06, 04:07 PM Thread Starter
 
Join Date: Oct 2006
Posts: 3
Re: 67 conv drivetrain questions

Thanks!

The engine runs strong and really pulls in the mid and top end. I am not sure what fuel issue could be causing bogging it but maybe I will change the fuel filter to be sure.

What did you change your rearend gears from and to? Are you paring them with a m-20 tranny?

The front end is solid and tight. I checked all components when I did the brake job. It only vibrates when braking and usually only when under 15mph.
dav_67 is offline  
 
post #4 of 7 (permalink) Old Oct 24th, 06, 04:44 PM
Gold Lifetime Member
Jim
 
Join Date: Dec 1999
Location: Yorkville, Illinois USA
Posts: 22,121
Re: 67 conv drivetrain questions

If it shakes under braking, you need to pull the wheels and take a look. First spin the rotors and eyeball for runout (wobble) If they wobble pull them off and have them turned. Then make sure the bearings and spindle are ok, regrease, put it back together, will be ok.





To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.



To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
New website for my vert is coming together. Do ya like the slide show on the home page?
JimM is offline  
post #5 of 7 (permalink) Old Oct 24th, 06, 05:31 PM
Senior Tech
Steve
 
thewebb1's Avatar
 
Join Date: Dec 2001
Location: Fergus,Ontario,Canada
Posts: 907
Re: 67 conv drivetrain questions

I agree with Jim. Check the wheels again. Bent rim maybe
I went from 2.73's to 3.73's with a M-21
What about the accelarator pump in carb, though that would be more hesitation than bogging Imho

67 Camaro RS350SS (already restored) 68Convertible(future project)
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

68 Coupe(restoring)On hold
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
Gave to friend.
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

67 Convertible (restoring)
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

67 Coupe(parts car for now)
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

72 Chevelle Malibu
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

2-69 Jaguar xke roadsters (appeasing the wife)


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
thewebb1 is offline  
post #6 of 7 (permalink) Old Oct 24th, 06, 07:07 PM
Tech Team
 
Join Date: Apr 2005
Posts: 83
Send a message via MSN to ExileMo Send a message via Skype™ to ExileMo
Re: 67 conv drivetrain questions

3.08's + mild motor + M21 = A lot of shaking off the line unless you "slip" the clutch or really tach up the motor.

I had 2.73 and M20, it was not fun to drive. A pain to get off the line and I could often smell the clutch dying. The feeling is similiar to trying to start out of 2nd or 3rd gear in a normal/modern car.

Changed my gears to 3.55 and it works great now.

As others stated, time to check front brakes for other shaking issues...

Mo West
----------------------

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


67 RS Convertible...
ExileMo is offline  
post #7 of 7 (permalink) Old Oct 25th, 06, 05:45 PM Thread Starter
 
Join Date: Oct 2006
Posts: 3
Re: 67 conv drivetrain questions

Solved shaking issue when braking. Loose tie rod sleeve on the drivers side.

Thanks for feedback on rearend gear ratio.

David
dav_67 is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Team Camaro Tech forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address.
NOTE we receive a lot of registrations with bad email addresses. IF you do not receive your confirmation email you will not be able to post. contact support and we will try and help.
Be sure you enter a valid email address and check your spam folder as well.



Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
305 exhaust questions camrod67 Engine 2 Aug 28th, 06 09:40 AM
67 RS headlight questions - Again. topspin Camaro Tech 13 Jul 13th, 06 03:17 PM
Rear shocks for '67 Camaro capt68 Brakes, Suspension & Steering 1 Jun 15th, 06 09:30 PM
Conv top questions drdave69 Interiors 4 Aug 9th, 01 01:55 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome