foot to the firewall.....clutch starts to engage if I even breath!!! - Team Camaro Tech
Troubleshooting Diagnosing problems done here.

 
LinkBack Thread Tools Display Modes
post #1 of 4 (permalink) Old Dec 19th, 06, 02:35 PM Thread Starter
Senior Tech
 
Join Date: Nov 2006
Location: Bend, OR
Posts: 1,702
foot to the firewall.....clutch starts to engage if I even breath!!!

I always thought that your clutch was going out when you barely press on the pedal and it starts to slip. Mine is just the opposite. I have to mash it to the floor and if I even flintch, it starts to engage. Are the pressure plate fingers shot??? What could it be??? Thanks!!!!
dubs68camaro is offline  
Sponsored Links
Advertisement
 
post #2 of 4 (permalink) Old Dec 19th, 06, 03:46 PM
Gold Lifetime Member
Kevin
 
SixtyAte's Avatar
 
Join Date: May 2005
Location: S. Eastern Massachusetts
Posts: 5,536
Re: foot to the firewall.....clutch starts to engage if I even breath!!!

You may have adjusted it wrong or used wrong parts. You should have about one inch free play. Get under and back off on the adjuster nut until the rod almost falls out of the fork then tighten it a little more and try it.

Kev
SixtyAte is offline  
post #3 of 4 (permalink) Old Dec 24th, 06, 03:42 PM
Senior Tech
Tom
 
Join Date: May 2001
Location: Socorro, New Mexico, USA
Posts: 574
Send a message via MSN to kausboy
Re: foot to the firewall.....clutch starts to engage if I even breath!!!

As your clutch wears your free play decreases. As SixtyAte said, adjust so you have about an inch of freeplay when the pedal is up. Often times when a pressure plate wears out they fail to disengage properly.
kausboy is offline  
 
post #4 of 4 (permalink) Old Dec 25th, 06, 04:15 PM Thread Starter
Senior Tech
 
Join Date: Nov 2006
Location: Bend, OR
Posts: 1,702
Re: foot to the firewall.....clutch starts to engage if I even breath!!!

Thanks guys!!!! Already got it fixed. Bought the truck thinking I was going to have to replace the clutch and it was just linkage REALLY out of adjustment. Thanks again!!!!

Dub
dubs68camaro is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Team Camaro Tech forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address.
NOTE we receive a lot of registrations with bad email addresses. IF you do not receive your confirmation email you will not be able to post. contact support and we will try and help.
Be sure you enter a valid email address and check your spam folder as well.



Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
Clutch setup/Adjustment paulm Transmission & Driveline 8 Sep 29th, 06 12:58 PM
Clutch fork hitting firewall 19673274sp Transmission & Driveline 5 Feb 8th, 05 10:47 AM
Clutch rod firewall boot CarlC Transmission & Driveline 6 Mar 26th, 04 12:36 PM
Clutch problems Camaro_Kyle Transmission & Driveline 5 Apr 8th, 03 04:37 AM
Firewall Boot for Clutch Rod Wing nut Tech 2001 2 Oct 27th, 01 12:10 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome