Horrible squeel when turning left - Team Camaro Tech
Troubleshooting Diagnosing problems done here.

 
LinkBack Thread Tools Display Modes
post #1 of 5 (permalink) Old Dec 31st, 06, 09:27 PM Thread Starter
Gold Lifetime Member
Dave
 
Join Date: Jun 2006
Location: Vacaville CA
Posts: 1,349
Horrible squeel when turning left

I went for a short cruise this afternoon. After driving about 5 to 6 miles I stopped at a 4 way stop. When I pulled away ,turning left, onto a side street a loud squeel came from under the hood. I continued on straight once I was in 3rd gear I put the trans in neutral and blipped the throttle. The noise went away. The next time I turned left, after coming to a stop, the squeel came back again, but went away as soon as I was driving in a straight line again.

When i got home I stopped in the driveway and waited for the garage door to open. When I proceeded to drive up into the garage, going straight, the squeel came back again. ????

I checked the P/S fluid level. It was about 1/4 inch over the hot mark on the little stick in the cap. The belts are not new but only have about 600 miles on them.

Ideas please..... new pump time or just a new belt?

Thanks,

Dave

Known to run with scissors....
__________
1969 Camaro Z/28 "clone", GMPP ZZ383, Autogear M22W, Moser 12bolt w/TruTrac 3:73.
Fred Mertz is offline  
Sponsored Links
Advertisement
 
post #2 of 5 (permalink) Old Dec 31st, 06, 11:50 PM
Gold Lifetime Member
Fred
 
Join Date: Nov 2006
Location: Seabeck WA
Posts: 8,375
Re: Horrible squeel when turning left

Fred, you can't check your belts by looking, you have to test the tension with a thumb press. (engine OFF of course) I'm sure your belt needs tightening. Happy New Year!

One owner 69 Camaro,(yep, bought it new
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
)
RS SS Hugger Orange, L88, 4:10's tru-tack posi, ducted hood, Endura, spoilers.
TH400 (CX) with Coan 8" converter, GV-OD, 8 track still on console and best et 10.495,
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
128.79mph 1.428 60'
All with 1960's stuff. (except tires and converter)
+ MT Super Scavenger headers & 3" full exhaust with X pipe. 3700 lbs. with me in it.
1000cfm AED and HD Harold-Lunati SR, 725 lift with shaft rockers too.
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
Fred Ficarra is offline  
post #3 of 5 (permalink) Old Jan 1st, 07, 04:22 AM
Gold Lifetime Member
Rick
 
Join Date: Feb 2000
Location: Accord, NY
Posts: 4,815
Re: Horrible squeel when turning left

Also, if they did squeal put a new belt on and recheck after you go for a drive. In my case, once the belt slipped it was never quiet again even when adjusted correctly. I also went with Dayco topcog belts which helped.

Rick Dorion
69 RS Conv therapy program, Autogear M22, 8-pt cage, with a new 410! SOLD
New therapy program - 68 Coupe. Will be survivor exterior, modern underpinnings! SOLD
67 Belair with perfect floors, pinchwelds and firewall. Hmmm!
RickD is offline  
 
post #4 of 5 (permalink) Old Jan 1st, 07, 06:48 AM
Senior Tech
Dave
 
Join Date: Oct 2005
Location: Rhode Island
Posts: 1,356
Re: Horrible squeel when turning left

Loose belt, as stated, is most likely culprit.

However, also check to make sure pulleys are correct and aligned properly. These old cars often have the engines in and out, or swapped from SB to BB or vice versa, so with all the changes that typically occur, sometimes the wrong pulleys and brackets are jury-rigged into position. You can check pulley alignment just by standing off to side of car and visually looking. Sometimes I use a long straight-edge metal ruler (laid against sides of pulleys) to confirm that alignment is kosher....

-

Dave F. in Rhode Island
'68 Camaro SS Accel DFI 454 (SOLD - I'm a boring Corvette owner now)
Bought my first big-block Chevy in 1970
Chevy-SS is offline  
post #5 of 5 (permalink) Old Jan 1st, 07, 07:55 PM Thread Starter
Gold Lifetime Member
Dave
 
Join Date: Jun 2006
Location: Vacaville CA
Posts: 1,349
Re: Horrible squeel when turning left

New belts did the trick. $20.00 and 20 minutes!

Thanks guys!

Dave

Known to run with scissors....
__________
1969 Camaro Z/28 "clone", GMPP ZZ383, Autogear M22W, Moser 12bolt w/TruTrac 3:73.
Fred Mertz is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Team Camaro Tech forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address.
NOTE we receive a lot of registrations with bad email addresses. IF you do not receive your confirmation email you will not be able to post. contact support and we will try and help.
Be sure you enter a valid email address and check your spam folder as well.



Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
Outer Left Tail Light Won't Light Up SFCamaro Electrical & Wiring 2 Oct 6th, 06 12:05 PM
Scraping noise from left front MCGOO Brakes, Suspension & Steering 7 Jun 2nd, 06 06:00 PM
69 rear turning lights & headlights? Frost Green 69 Electrical & Wiring 1 Oct 10th, 05 06:55 AM
Left turn vibration? stevo camaro Brakes, Suspension & Steering 3 Jul 16th, 04 07:42 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome