68 camaro with 650 holley problems - Team Camaro Tech
Troubleshooting Diagnosing problems done here.

 
LinkBack Thread Tools Display Modes
post #1 of 3 (permalink) Old Jan 13th, 07, 02:24 PM Thread Starter
Senior Tech
Josh
 
Join Date: Jan 2007
Location: high point nc
Posts: 162
68 camaro with 650 holley problems

i got a 68 camaro with the 650 holley and i was jjust wandering how i could maybe lean it out a lil i guess, it has vacum secondaries and i did sumtin someone told me to do and put a bolt so it would come in all the time.....but ive had about 5 friends in the past month say when they ride behind me they can "smell" gas from how rich my car is running ?..i dont smell gas so i dunno, but is that bolt idea a good thing or prolly makes it slower ?
ridinbikes247 is offline  
Sponsored Links
Advertisement
 
post #2 of 3 (permalink) Old Jan 13th, 07, 05:47 PM
Senior Tech
Phil
 
Join Date: Dec 2006
Location: Cary NC
Posts: 100
Re: 68 camaro with 650 holley problems

Man take that bolt out! Your car will never perform like it can with the bolt opening the secondaries like that. Find you a 650 double pumper if you want to have mechanical secondaries. Another issues with the "gas smell" could be timing. What ignition system do you have?
67 Bassman is offline  
post #3 of 3 (permalink) Old Jan 16th, 07, 06:21 AM
Senior Tech
Dave
 
Join Date: Oct 2005
Location: Rhode Island
Posts: 1,356
Re: 68 camaro with 650 holley problems

Your jetting could be too rich, you could have a vacuum leak, your plugs or wires could be bad, etc, etc. Lots of things could produce a "gas smell". Plus, if you're running a big cam, then you'll get that gas smell even if it's tuned perfectly.................

But I agree with Bassman, take the screw out. The screw trick doesn't add fuel when secondaries open, so you will get a bog. A "double-pumper" carb has two accelerator pumps, with the secondaries having their own pump. This provides the extra fuel when you stomp it.

-

Dave F. in Rhode Island
'68 Camaro SS Accel DFI 454 (SOLD - I'm a boring Corvette owner now)
Bought my first big-block Chevy in 1970
Chevy-SS is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Team Camaro Tech forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address.
NOTE we receive a lot of registrations with bad email addresses. IF you do not receive your confirmation email you will not be able to post. contact support and we will try and help.
Be sure you enter a valid email address and check your spam folder as well.



Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
69 Camaros on television and movies jsg1010z Bench Racing 35 Aug 15th, 10 05:28 PM
68 Camaro Paint list tronic72 Body Shop 1 Jan 21st, 06 03:20 AM
92 Camaro 5.0 TBI - Shutting off Problems Mongo0se Troubleshooting 8 Jan 11th, 06 05:56 PM
68 Camaro quarter panels 1968camarossrs-350 Body Shop 7 Jan 8th, 06 04:28 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome