Car losses power when i give it gas - Team Camaro Tech
Troubleshooting Diagnosing problems done here.

 
LinkBack Thread Tools Display Modes
post #1 of 13 (permalink) Old Feb 1st, 07, 03:50 PM Thread Starter
 
Join Date: Feb 2007
Location: earth
Posts: 3
Car losses power when i give it gas

Hello, this is my first post and I hope someone can help. I have a 1990 IROC with a 305 TPI. When I give it gas it losses power, when I let off the gas it rev's up then drops back down to idle. I replaced the cap, rotor, plugs, plug wires, checked all vacuum lines for leaks, cleaned and oiled K&N air filters, put in a new O2 sensor and drove it for an hour. None of these things worked but I did notice that when the car is in park or neutral I can rev the car with only a slight hesitation at the start. When I put the car in drive and give it gas thatís when it losses power or dies.


Any suggestions?
nece$$aryevil is offline  
Sponsored Links
Advertisement
 
post #2 of 13 (permalink) Old Feb 1st, 07, 03:54 PM
Senior Tech
David
 
Join Date: May 1999
Location: Jefferson City, MO.
Posts: 621
Re: Car losses power when i give it gas

replace the fuel filter

67 RS marina blue, 406 ,M20 4spd, 9". car has been in my family since new!

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
67FREAK is offline  
post #3 of 13 (permalink) Old Feb 1st, 07, 04:00 PM Thread Starter
 
Join Date: Feb 2007
Location: earth
Posts: 3
Re: Car losses power when i give it gas

oops, thats the first thing I did.
nece$$aryevil is offline  
 
post #4 of 13 (permalink) Old Feb 1st, 07, 04:11 PM
Senior Tech
mike
 
Join Date: Jan 2007
Location: connecticut
Posts: 1,163
Re: Car losses power when i give it gas

check the map sensor
kustomwerker is offline  
post #5 of 13 (permalink) Old Feb 1st, 07, 05:02 PM
Senior Tech
george
 
Join Date: Sep 2006
Location: detroit
Posts: 2,289
Re: Car losses power when i give it gas

try driving the car with the mass air flow sensor disconnected.You will find this between the air filters and the throttle body.Some MAF sensors do not like aftermarket filters,especially oiled ones.You can carb clean the MAF hot wires first before replacing the sensor if needed.
fatblock is offline  
post #6 of 13 (permalink) Old Feb 1st, 07, 05:18 PM Thread Starter
 
Join Date: Feb 2007
Location: earth
Posts: 3
Re: Car losses power when i give it gas

How do I check the map sensor? Can I use the same method as fatblock suggested with the mass air flow sensor?
nece$$aryevil is offline  
post #7 of 13 (permalink) Old Feb 1st, 07, 08:04 PM
Senior Tech
mike
 
Join Date: Jan 2007
Location: connecticut
Posts: 1,163
Re: Car losses power when i give it gas

i believe 90 is speed density, therefore does not have a mass air sensor...the map sensor(manifold absolute pressure) is a little rectangular black plastic box with a vacuum line going to it, and a 3 wire connector...try tapping on it while the car is at idle...if the idle changes, change the map...its only like 35 bucks new, so u might want to just invest in 1 anyway, as alot of drivability problems stem from a flaky map...
kustomwerker is offline  
post #8 of 13 (permalink) Old Feb 13th, 07, 04:50 PM
Senior Tech
bill
 
Join Date: Jan 2007
Location: new jersey
Posts: 601
Re: Car losses power when i give it gas

i agree with fatblock since aftermarket filters you oil. oil on a mass sensor throws it all off. with driveability problems and transmission not shifting right also.
jaguareats is offline  
post #9 of 13 (permalink) Old Feb 13th, 07, 05:05 PM
Senior Tech
mike
 
Join Date: Jan 2007
Location: connecticut
Posts: 1,163
Re: Car losses power when i give it gas

the maf sensor has a "burnoff" mode that heats up the sensor wire and cooks off any road grime and oil that may get on it, but as stated above this could be the problem if this is a maf system...but as i said earlier, 90 was the first year for speed density, hence the map sensor...this system measures manifold vacuum instead of incoming air volume...the maf sensor is inline in the air intake...its black in color. and round with a square box and 5 wire(i believe) connecter on it...the map sensor is a rectangular sensor that has a single vacuum line connected to it...its usually bolted next to the coil, but i dont remember if yours is there or plugged directly to the intake...have you ever done a fuel pump...check for pressure drop with a guage when you rev it up...also check for a plugged cat...it really sounds like a lean condition though...
kustomwerker is offline  
post #10 of 13 (permalink) Old Feb 13th, 07, 06:31 PM
Senior Tech
george
 
Join Date: Sep 2006
Location: detroit
Posts: 2,289
Re: Car losses power when i give it gas

Quote:
Originally Posted by kustomwerker View Post
i believe 90 is speed density, therefore does not have a mass air sensor...the map sensor(manifold absolute pressure) is a little rectangular black plastic box with a vacuum line going to it, and a 3 wire connector...try tapping on it while the car is at idle...if the idle changes, change the map...its only like 35 bucks new, so u might want to just invest in 1 anyway, as alot of drivability problems stem from a flaky map...
I think the 85 to 92 305,s use a MAF sensor.Maybe the 5.7L is what your thinking?(speed density).
fatblock is offline  
post #11 of 13 (permalink) Old Feb 13th, 07, 06:47 PM
Gold Lifetime Member
Harley
 
wiskeesour's Avatar
 
Join Date: Nov 2006
Location: A van. Down by the river.
Posts: 6,359
Send a message via Yahoo to wiskeesour
Re: Car losses power when i give it gas

85-87 tpi- maf, 88-92 tpi -speed density. 305's 350's doesnt matter. pretty positive on that.

AE2(AW) Harley Moody, USNavy
"Master-at-Arms" for the CDWJB!!
November 26th, 2008 was my last day to serve my country as a member of the World's Greatest Navy.
Thanks Chief.
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
wiskeesour is offline  
post #12 of 13 (permalink) Old Feb 13th, 07, 07:16 PM
Senior Tech
george
 
Join Date: Sep 2006
Location: detroit
Posts: 2,289
Re: Car losses power when i give it gas

Quote:
Originally Posted by wiskeesour View Post
85-87 tpi- maf, 88-92 tpi -speed density. 305's 350's doesnt matter. pretty positive on that.
Yep,they went to MAP in 90.The tap test on the map sensor is a good starting point as previously mentioned.Hard to keep track with all the mid year 1st 2nd design the oems throw atcha.
fatblock is offline  
post #13 of 13 (permalink) Old Feb 13th, 07, 07:23 PM
Senior Tech
mike
 
Join Date: Jan 2007
Location: connecticut
Posts: 1,163
Re: Car losses power when i give it gas

go to chevythunder.com for some pretty indepth tpi stuff...lots of info about them there...
kustomwerker is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Team Camaro Tech forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address.
NOTE we receive a lot of registrations with bad email addresses. IF you do not receive your confirmation email you will not be able to post. contact support and we will try and help.
Be sure you enter a valid email address and check your spam folder as well.



Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
69 Camaros on television and movies jsg1010z Bench Racing 35 Aug 15th, 10 05:28 PM
We are being sued about car originality shawn56 Tag Team 105 Nov 12th, 06 08:36 PM
Horrible gas milage...power valve?? J early Troubleshooting 26 Aug 24th, 06 04:33 AM
Car Running....Then lost all power to Ignition! HELP jsabowabo Electrical & Wiring 10 Jul 20th, 06 05:40 PM
Which car would you buy? South Side Goons & Hitmen Bench Racing 10 Jun 23rd, 06 10:11 AM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome