HELP!! no brakes,new vert, nice day, wana cruise - Team Camaro Tech
Brakes, Suspension & Steering Conversion questions, Steering & Handling

 
LinkBack Thread Tools Display Modes
post #1 of 7 (permalink) Old Apr 22nd, 07, 07:08 AM Thread Starter
Gold Lifetime Member
jimmy
 
Join Date: Apr 2007
Location: Kensington, Md.
Posts: 92
HELP!! no brakes,new vert, nice day, wana cruise

Hello all, I am brand new this morning. Just purchased 1967 ss 350 convertible, 4 speed, front disc brakes. Brought it home last weekend, brakes seemed ok. I went DMV and got tags (always a treat). Wanted to take on initial run so I checked the fluids. Front Reservoir empty !! So I filled it up and enlisted wife for pumping duty. Right front caliper ---no air. Left front-- nothing but air. Filled and pumped two complete reservoir's worth. No luck. No visable leaks. But when you go to refill master cylinder, front reservoir is full of tiny bubbles. Question: is my master cylinder gone ? OK Guys be gentle, this is my first time. Thanks in advance. Gypsy Jim
gypsy jim is offline  
Sponsored Links
Advertisement
 
post #2 of 7 (permalink) Old Apr 22nd, 07, 09:17 AM
Senior Tech
john
 
wagonman's Avatar
 
Join Date: Oct 2004
Location: northern california
Posts: 2,796
Re: HELP!! no brakes,new vert, nice day, wana cruise

you really need to remove your tires,pull the rear drums and do a visual inspection of all four corners!! if the master was empty,there probably is a reason..

we need to keep you around!!!!

Remember,I'm not making this stuff up!

1969 rs/ss 396 350hp/4spd conv a/c,pw,ps,foldown
1968 Z/28 crossram- j/l8 conv pw,ps,foldown
1963 nova ss 350/4spd conv a/c,ps,pt
1963 nova 400 4dr 6cyl/700r4 a/c
2006 GT/5spd mustang conv
wagonman is offline  
post #3 of 7 (permalink) Old Apr 22nd, 07, 09:21 AM
Senior Tech
 
Join Date: Jul 2005
Location: South Florida
Posts: 967
Re: HELP!! no brakes,new vert, nice day, wana cruise

usually leaking wheel cylinders is a problem w/ these cars. Sometimes you can't even see the leaks. They rust and then sieze up causing problems.
m21man is offline  
 
post #4 of 7 (permalink) Old Apr 22nd, 07, 01:11 PM
Senior Tech
Blaine
 
Join Date: Mar 2006
Location: Lodi,California
Posts: 540
Re: HELP!! no brakes,new vert, nice day, wana cruise

you have a leak some where brake fluid just doesn't evaporate! By the way jimmy welcome to team camaro you will get a lot of help and info here.

Don't forget to post your results
it's good for the thread
My 67 RS/SS/396

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
blainedoe is offline  
post #5 of 7 (permalink) Old Apr 22nd, 07, 05:01 PM
Senior Tech
bill
 
Join Date: Jan 2007
Location: new jersey
Posts: 601
Re: HELP!! no brakes,new vert, nice day, wana cruise

if you keep getting air in master sounds like you got a bad brake line. when you release the brake it sucks in air.
jaguareats is offline  
post #6 of 7 (permalink) Old Apr 22nd, 07, 10:00 PM
Senior Tech
Jon
 
Rodder's Avatar
 
Join Date: Jul 2006
Location: Roswell, GA
Posts: 1,431
Send a message via AIM to Rodder Send a message via Yahoo to Rodder
Re: HELP!! no brakes,new vert, nice day, wana cruise

I agree with everyone else here, you need to find where it was leaking and fix that. One additional thing though: if you sucked the master cylinder dry, you need to pull it out and bench bleed it.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
- LS1, T56, Hooker longtubes, Autokraft pan & mounts, GM LS7 clutch, Borla ProXS, Moser/Strange/Wilwood 9", Covans dash, UltraLite IIs, Procar Elites, Vintage Air GEN-IV, AGR 12:1 steering, Addco swaybars, Hydratech hydroboost
Rodder is offline  
post #7 of 7 (permalink) Old Apr 23rd, 07, 04:20 PM Thread Starter
Gold Lifetime Member
jimmy
 
Join Date: Apr 2007
Location: Kensington, Md.
Posts: 92
Re: HELP!! no brakes,new vert, nice day, wana cruise

Thanks to everyone for the warm welcome and good advice. I am in the process of tracking down the problem. You gotta have stop before you can go. My car is a long way from looking like most of yours but will post pics asap. Thanks again, Jimmy

gypsy jim is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Team Camaro Tech forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address.
NOTE we receive a lot of registrations with bad email addresses. IF you do not receive your confirmation email you will not be able to post. contact support and we will try and help.
Be sure you enter a valid email address and check your spam folder as well.



Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
Nice December day, brought her outside to idle a bit jr68 Bench Racing 9 Dec 17th, 06 04:05 PM
A few quick pics of the '69 RS Z/28... SinCityRSZ28 Bench Racing 15 Dec 12th, 06 05:36 PM
nice day to have a 69 vert out for a ride angelglo Bench Racing 2 Nov 19th, 06 12:47 PM
Nice day finally- pic of the 69 Tubbed69 Camaros.net Site Help Discussion 0 Apr 10th, 05 07:18 PM
Nice cruise night at Hooters! Jeff H Bench Racing 3 Jul 30th, 04 06:16 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome