Help with 67 front sway bar please - Team Camaro Tech
Brakes, Suspension & Steering Conversion questions, Steering & Handling

 
LinkBack Thread Tools Display Modes
post #1 of 8 (permalink) Old May 19th, 08, 07:42 AM Thread Starter
Senior Tech
Mike
 
Join Date: Jul 2006
Location: Mount Albert, Ontario, Canada
Posts: 159
Help with 67 front sway bar please

Ive been stalling putting my stock sway bar in since it didnt seem to fit, but since there was no weight on the suspension i decided to wait until the drivetrain was in. So i installed my BB engine this weekend, and the sway still does not seem to fit correctly...close, but it seems to bind and I cant maneuver it enough to get the end links connected. I had to drop one of the lower control arms off just to get it in and it was a major pain to get it lined up again to rebolt it. Finally the bar is in place, but doesnt seem right and Im beginning to wonder if I even have the correct bar (it came with the car but was not installed)...or perhaps my upgrade to QA1 coilovers has changed the geometry enough to render the bar unuseable?? Any thoughts?
thanks

________________________________
Mike
1967 RS 460 BB, TKO 600, 3.42 12 Bolt posi
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
mpaq is offline  
Sponsored Links
Advertisement
 
post #2 of 8 (permalink) Old May 19th, 08, 07:53 AM
DjD
Retired
Dennis
 
DjD's Avatar
 
Join Date: Apr 1999
Location: Fortuna, CA
Posts: 26,430
Garage
Re: Help with 67 front sway bar please

Is the bar upsidedown by chance?

...Dennis

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


"Don't take life so serious, you won't get out alive..."
DjD is offline  
post #3 of 8 (permalink) Old May 19th, 08, 09:16 AM
Senior Tech
Joe A
 
Join Date: Feb 2007
Location: Newton NH
Posts: 414
Re: Help with 67 front sway bar please

I was thinking the same thing. The center part of the say bar should face down to clear the damper. If you have that in the correct orientation then I would connect the end links first...Then to the braces on the subframe. If you are still off then post a pic of the bar so we can see what you have.

1967 SS 350 Clone ( not hiding it )
Never Ending Project

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
camjoe63 is offline  
 
post #4 of 8 (permalink) Old May 19th, 08, 10:10 AM
Tech Team
Ken
 
Join Date: May 2006
Location: Lakeville, MA
Posts: 40
Re: Help with 67 front sway bar please

Mike , Sorry I have no input related to your sway bar problem. But I did take note of what you are running for the engine and drivetrain. I am running a 502 with the exact same set up for trans and rear end and gears. I am wondering if you have had it on the street and experienced what that combo feels like. I have been working on mine for a few years and expect fo have it on the street within 6 months or so. Thanks, Ken.
Ken Packard is offline  
post #5 of 8 (permalink) Old May 19th, 08, 05:33 PM
Banned
 
Join Date: Apr 2000
Location: Columbia, MO USA
Posts: 21,341
Smile Re: Help with 67 front sway bar please

My 1" ADDCO slid right in once I finally figured out how to kick, cuss and shove it in there!

Our S/B's ends are square to it so you should be able to tell if it is like a stock one easy.
Not angled like some others..

Like this..

.......l.......................................... ...l
.......l.......................................... ...l
.......\___________________________/

Not like this..

.......\.......................................... .../
.........\........................................ ./
.......... \_______________________/

Hope this helps..

pdq67



pdq67 is offline  
post #6 of 8 (permalink) Old May 19th, 08, 07:50 PM Thread Starter
Senior Tech
Mike
 
Join Date: Jul 2006
Location: Mount Albert, Ontario, Canada
Posts: 159
Re: Help with 67 front sway bar please

Thanks guys, problem solved, i had it in wrong from the getgo so had to drop the control arm again to get it out, but it went back in no problem and fits good now.

Ken: This is a ground up build for me and its never been on the road yet and wont be before yours so I'd be anxious to hear your first experience...I had a TKO600 in my previous car, but it was a small block with 3:73 gears. Liked it so much i bought another one for this build, but the car came with a rebuilt 12bolt and new gears so Im not going to change unless I feel the need...Im thinking the extra torque of the big block will make up for the 3:42's currently in there. Besides with mono leaf springs and non staggered shocks on the 67 its kind of pointless going to a numerically higher gear, I expect it would just hop all over the place...

________________________________
Mike
1967 RS 460 BB, TKO 600, 3.42 12 Bolt posi
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
mpaq is offline  
post #7 of 8 (permalink) Old May 19th, 08, 11:10 PM
Senior Tech
Jon
 
Rodder's Avatar
 
Join Date: Jul 2006
Location: Roswell, GA
Posts: 1,431
Send a message via AIM to Rodder Send a message via Yahoo to Rodder
Re: Help with 67 front sway bar please

Quote:
Originally Posted by pdq67 View Post
My 1" ADDCO slid right in once I finally figured out how to kick, cuss and shove it in there!
pdq67
My 1 1/8 Addco required two Ford tools and a spring "spreader" to get it through my springs.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
- LS1, T56, Hooker longtubes, Autokraft pan & mounts, GM LS7 clutch, Borla ProXS, Moser/Strange/Wilwood 9", Covans dash, UltraLite IIs, Procar Elites, Vintage Air GEN-IV, AGR 12:1 steering, Addco swaybars, Hydratech hydroboost
Rodder is offline  
post #8 of 8 (permalink) Old May 20th, 08, 05:11 AM
Banned
 
Join Date: Apr 2000
Location: Columbia, MO USA
Posts: 21,341
Re: Help with 67 front sway bar please

Don't doubt it at all.

He, He!!

It's all in how you hold your mouth!!

He, He!!

pdq67



pdq67 is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Team Camaro Tech forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address.
NOTE we receive a lot of registrations with bad email addresses. IF you do not receive your confirmation email you will not be able to post. contact support and we will try and help.
Be sure you enter a valid email address and check your spam folder as well.



Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome