Travel for launch yet level for high speeds - Team Camaro Tech
Brakes, Suspension & Steering Conversion questions, Steering & Handling

 
LinkBack Thread Tools Display Modes
post #1 of 2 (permalink) Old Mar 20th, 09, 08:17 PM Thread Starter
Rob
 
Join Date: Mar 2009
Location: Vancouver BC Canada
Posts: 27
Travel for launch yet level for high speeds

I have a 81 camaro w/ 427 doin some heavey mods.

I've been thinkin of a way I can get your typical drag ride angle for launch, then somehow maintain a low and level ride for the higher speeds?! I'm pretty sure bags are gonna come into play here... but I have little knowledge of the versatility of them?!

When bags are deflated... what's the rebound like? Is there gonna be slack?

Can a 1 way psi check valve be installed to allow deflation upon launch and lock closed afterwards?

I'd like the bags to give about 4" extra travel upon launch and lock shut at deflation then allow the stock suspension to take over.

Can I do this? Any other suggestions?
Mad Max is offline  
Sponsored Links
Advertisement
 
post #2 of 2 (permalink) Old Mar 20th, 09, 10:40 PM Thread Starter
Rob
 
Join Date: Mar 2009
Location: Vancouver BC Canada
Posts: 27
Re: Travel for launch yet level for high speeds

Okay... here's what I would like to do! With the bags mounted on the inside of the leafs from the axle to the subframe.

1st... With bag fully inflated for launch:
The downward force of the launch will compress the bag to a rate of psi where an exaust check valve will release air from the bag at a controled rate to maximize the rear travel for longer duration of traction.
I'd like to get 6-8" bag travel.
Will this work? Can this be done? Is it logical? I dunno... you tell me!

For the fun of it....

2nd Auto re-inflation: 2 stages, deceleration to 70km/h inflates to 1/2 and at 40 to full. Even if it acts like a dimmer switch or a wiper speed relay... for the slow accelerations.

Would be nice to have a lock out or a manual adjust inboard.

3rd Auto deflate... same as above but opposite!

Last edited by Mad Max; Mar 20th, 09 at 10:42 PM. Reason: adding
Mad Max is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Team Camaro Tech forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address.
NOTE we receive a lot of registrations with bad email addresses. IF you do not receive your confirmation email you will not be able to post. contact support and we will try and help.
Be sure you enter a valid email address and check your spam folder as well.



Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome