Power Steering - Low Pressure Hose Problem (Pics) - Team Camaro Tech
Brakes, Suspension & Steering Conversion questions, Steering & Handling

 
LinkBack Thread Tools Display Modes
post #1 of 4 (permalink) Old Feb 20th, 10, 03:30 PM Thread Starter
Tech Team
Brandon
 
Join Date: Oct 2005
Location: Friendswood, TX (Houston)
Posts: 71
Power Steering - Low Pressure Hose Problem (Pics)

It seems like the simplest things slow you down...

I'm trying to attach my low pressure hose to the male outlet from the power steering pump on my 67. I'm using the original power steering box with a Tuff Stuff Saginaw pump and high quality rubber hoses. I cannot get the low pressure hose (3/8") over the rib of the male outlet. The hose is rubber, but it has braided steel embedded in the rubber. The braided steel will not let the hose go over the rib more than 1/8" so T can put on the hose clamp.

Any ideas...cut the rib off??? See pics below. Thanks!!!




Brandon
67 Butternut RS 4spd. Muncie w/ OD (0.87 4th)
408CI w/ 508HP/530TQ
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
, 12 Bolt, Hotchkis Springs, 3" Magnaflow
Wilwood Brakes, March Pulleys, Vintage Air, Foose Legends

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
brandonvelek is offline  
Sponsored Links
Advertisement
 
post #2 of 4 (permalink) Old Feb 20th, 10, 03:34 PM
Gold Lifetime Member
Daryl
 
1968RallySport's Avatar
 
Join Date: Apr 2007
Location: Northern California
Posts: 953
Garage
Re: Power Steering - Low Pressure Hose Problem (Pics)

try lubing the inside of the hose with STP...........
1968RallySport is offline  
post #3 of 4 (permalink) Old Feb 21st, 10, 02:37 PM Thread Starter
Tech Team
Brandon
 
Join Date: Oct 2005
Location: Friendswood, TX (Houston)
Posts: 71
Re: Power Steering - Low Pressure Hose Problem (Pics)

Nevermind. I got it on, finally. I had to twist it on using a lot of force. It is amazing how little a braided hose gives. Thx.

Brandon
67 Butternut RS 4spd. Muncie w/ OD (0.87 4th)
408CI w/ 508HP/530TQ
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
, 12 Bolt, Hotchkis Springs, 3" Magnaflow
Wilwood Brakes, March Pulleys, Vintage Air, Foose Legends

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
brandonvelek is offline  
 
post #4 of 4 (permalink) Old Feb 21st, 10, 09:13 PM
Moderator
David Pozzi
 
davidpozzi's Avatar
 
Join Date: Nov 1999
Location: Central California, USA
Posts: 10,061
Re: Power Steering - Low Pressure Hose Problem (Pics)

Yes the braided stuff won't give enough. Some hose is slightly smaller ID than std automotive hose too. Steel braided hose is way overkill for a return hose.

Check my web page for First Gen Camaro suspension info:
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

67 RS 327 original owner. 1965 Lola T-70
davidpozzi is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Team Camaro Tech forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address.
NOTE we receive a lot of registrations with bad email addresses. IF you do not receive your confirmation email you will not be able to post. contact support and we will try and help.
Be sure you enter a valid email address and check your spam folder as well.



Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome